[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Pulp-list] Pulp-list Digest, Vol 63, Issue 15




> Date: Tue, 17 Feb 2015 10:07:07 -0500
> From: Randy Barlow <rbarlow redhat com>
> To: pulp-list redhat com
> Subject: Re: [Pulp-list] Problems syncing RHEL 7 source
> Message-ID: <54E3591B 6010900 redhat com>
> Content-Type: text/plain; charset=windows-1252
>
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> On 02/17/2015 08:37 AM, Paul Jochum wrote:
> Feb 17 07:32:51 lss-pulp02 pulp:
> pulp_rpm.plugins.importers.yum.sync:ERROR:   File
> "/usr/lib/python2.6/site-packages/pulp_rpm/plugins/importers/yum/repomd/packages.py",
>
>
> line 53, in package_list_generator
> Feb 17 07:32:51 lss-pulp02 pulp:
> pulp_rpm.plugins.importers.yum.sync:ERROR:     for event, element
> in xml_iterator: Feb 17 07:32:51 lss-pulp02 pulp:
> pulp_rpm.plugins.importers.yum.sync:ERROR:   File "<string>", line
> 68, in __iter__ Feb 17 07:32:51 lss-pulp02 pulp:
> pulp_rpm.plugins.importers.yum.sync:ERROR: SyntaxError: no element
> found: line 3758, column 0
>
> It sounds like Pulp is failing to parse the XML data. Either the XML
> data in the repo is invalid, or this is a bug in Pulp. I'm not sure
> which. Are others having any trouble syncing RHEL 7?
Hi Randy:

I am syncing 9 repos (all RHEL 7 based, directly from Red Hat), but only have problems with 2 of them, the rest are fine.

rhel-x86_64-server-software-collections-7
rhel-x86_64-server-supplementary-7
rhel-x86_64-server-optional-7
rhel-x86_64-server-extras-7
rhel-x86_64-server-7-kickstart
rhel-x86_64-server-7-source
rhel-x86_64-server-debug-7
rhel-x86_64-server-common-7
rhel-x86_64-server-7

thanks,
Paul


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]