[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Pulp-list] Issue in Target repository republish after a copy



Dear Barnaby,

I have received couple of assistance from consultants and found the issue.I will test it now.

Basically I have 2 issues in my testing

1. Instead of rhel repo ,I am pointed to centos which is wrong and wont help for redhat Linux clients.

2. I have missed the serve http option (--serve-http true) while copy the repo.

Thanks,
BVIJAY

On Fri, Feb 20, 2015 at 3:37 AM, Vijayabalan Balakrishnan <bvijaycom gmail com> wrote:
Hi,

I have copied pasted the commands from correct POC server.

Create the master repo with origin feed

# pulp-admin rpm repo create --repo-id master_rhel6_st_repo --retain-old-count 2 --serve-http true --relative-url master_rhel6_st_repo --feed http://mirror.centos.org/centos/7/updates/x86_64/

Sync and download all the rpms from origin

# pulp-admin rpm repo sync run --repo-id master_rhel6_st_repo

Now i have created new empty repo

# pulp-admin rpm repo create --repo-id=pulp-snapshot

Taking snapshot/copy from master repo.

# pulp-admin rpm repo copy rpm --from-repo-id=master_rhel6_st_repo --to-repo-id=pulp-snapshot

Now even i have published manually through following command also this repository is not showing via http ...

# pulp-admin rpm repo publish run --repo-id pulp-snapshot


I have executed several times the above command and still if i access the following url this pulp-snapshot is not showing...

Pulp Server = 192.168.1.1


In this url i am seeing the master repository only


but http://192.168.1.1/pulp/repos/pulp-snapshot is not coming ?

Any idea ?



On Fri, Feb 20, 2015 at 3:18 AM, Barnaby Court <bcourt redhat com> wrote:
Hi, I'm not sure but it looks like a misname of the repos.  In your first command you created a repo with the id master_rhel6_st_repo but then you performed a sync on origin_master_centos6_st_repo.  You then copied content from origin_master_centos6_st_repo->1Q2015-dev-rhel6 even though you looked at the repo details for pulp-snapshot to validate the transfer.  Could you dpaste the full shell session from creation of the repos through the final publish & repo list?

-Barnaby

----- Original Message -----
From: "Vijayabalan Balakrishnan" <bvijaycom gmail com>
To: pulp-list redhat com
Sent: Thursday, February 19, 2015 3:19:57 PM
Subject: [Pulp-list] Issue in Target repository republish after a copy


In my POC environment after i copy the repository even if i publish also not accessible via http. is it a bug ?

Help needed ...


Create the master repo with origin feed


# pulp-admin rpm repo create --repo-id master_rhel6_st_repo --retain-old-count 2 --serve-http true --relative-url epel-6 --feed http://mirror.centos.org/centos/7/updates/x86_64/

Sync and download all the rpms from origin

# pulp-admin rpm repo sync run --repo-id origin_master_centos6_st_repo

Now i am created new empty repo

# pulp-admin rpm repo create --repo-id=pulp-snapshot

Taking snapshot/copy from master repo.

# pulp-admin rpm repo copy rpm --from-repo-id=origin_master_centos6_st_repo --to-repo-id=1Q2015-dev-rhel6

Now even i have published manually through following command also this repository is not showing via http ...

# pulp-admin rpm repo publish run --repo-id pulp-snapshot

I have executed several times the above command and still if i access the following url this pulp-snapshot is not showing...

Pulp Server = 192.168.1.1

http://192.168.1.1/pulp/repos/



In this url i am seeing the master repository only
http://192.168.1.1/pulp/repos/master_rhel6_st_repo



but http://192.168.1.1/pulp/repos/pulp-snapshot is not coming ?

Any idea ?

_______________________________________________
Pulp-list mailing list
Pulp-list redhat com
https://www.redhat.com/mailman/listinfo/pulp-list



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]