[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Pulp-list] groupinstall pulp-consumer-quid quitting with dependency errors



When trying to install the pulp consumer for RHEL 6, it seems that python-quid is not available.  Is there a work around for this?

sudo yum groupinstall pulp-consumer-qpid
Loaded plugins: product-id, refresh-packagekit, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Setting up Group Process
pulp                                                                                  | 3.6 kB     00:00
Package pulp-consumer-client-2.8.0-1.el6.noarch already installed and latest version
Package pulp-rpm-consumer-extensions-2.8.0-1.el6.noarch already installed and latest version
Package pulp-agent-2.8.0-1.el6.noarch already installed and latest version
Package pulp-rpm-handlers-2.8.0-1.el6.noarch already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package pulp-puppet-consumer-extensions.noarch 0:2.8.0-1.el6 will be installed
--> Processing Dependency: python-pulp-puppet-common = 2.8.0 for package: pulp-puppet-consumer-extensions-2.8.0-1.el6.noarch
---> Package pulp-puppet-handlers.noarch 0:2.8.0-1.el6 will be installed
--> Processing Dependency: puppet >= 2.7.14 for package: pulp-puppet-handlers-2.8.0-1.el6.noarch
---> Package pulp-rpm-yumplugins.noarch 0:2.8.0-1.el6 will be installed
---> Package python-gofer-qpid.noarch 0:2.7.5-1.el6 will be installed
--> Processing Dependency: python-qpid >= 0.18 for package: python-gofer-qpid-2.7.5-1.el6.noarch
--> Running transaction check
---> Package puppet.noarch 0:2.7.26-2.el6 will be installed
--> Processing Dependency: facter < 1:2.0 for package: puppet-2.7.26-2.el6.noarch
--> Processing Dependency: ruby(abi) >= 1.8 for package: puppet-2.7.26-2.el6.noarch
--> Processing Dependency: ruby >= 1.8.5 for package: puppet-2.7.26-2.el6.noarch
--> Processing Dependency: facter >= 1.5 for package: puppet-2.7.26-2.el6.noarch
--> Processing Dependency: ruby-shadow for package: puppet-2.7.26-2.el6.noarch
--> Processing Dependency: ruby-augeas for package: puppet-2.7.26-2.el6.noarch
--> Processing Dependency: ruby(selinux) for package: puppet-2.7.26-2.el6.noarch
--> Processing Dependency: /usr/bin/ruby for package: puppet-2.7.26-2.el6.noarch
---> Package python-gofer-qpid.noarch 0:2.7.5-1.el6 will be installed
--> Processing Dependency: python-qpid >= 0.18 for package: python-gofer-qpid-2.7.5-1.el6.noarch
---> Package python-pulp-puppet-common.noarch 0:2.8.0-1.el6 will be installed
--> Running transaction check
---> Package facter.x86_64 0:1.6.18-8.el6 will be installed
---> Package libselinux-ruby.x86_64 0:2.0.94-5.8.el6 will be installed
---> Package python-gofer-qpid.noarch 0:2.7.5-1.el6 will be installed
--> Processing Dependency: python-qpid >= 0.18 for package: python-gofer-qpid-2.7.5-1.el6.noarch
---> Package ruby.x86_64 0:1.8.7.374-4.el6_6 will be installed
---> Package ruby-augeas.x86_64 0:0.4.1-1.el6 will be installed
---> Package ruby-libs.x86_64 0:1.8.7.374-4.el6_6 will be installed
--> Processing Dependency: libreadline.so.5()(64bit) for package: ruby-libs-1.8.7.374-4.el6_6.x86_64
---> Package ruby-shadow.x86_64 0:1.4.1-13.el6 will be installed
--> Running transaction check
---> Package compat-readline5.x86_64 0:5.2-17.1.el6 will be installed
---> Package python-gofer-qpid.noarch 0:2.7.5-1.el6 will be installed
--> Processing Dependency: python-qpid >= 0.18 for package: python-gofer-qpid-2.7.5-1.el6.noarch
--> Finished Dependency Resolution
Error: Package: python-gofer-qpid-2.7.5-1.el6.noarch (pulp)
           Requires: python-qpid >= 0.18
           Available: python-qpid-0.14-11.el6_3.noarch (InstallMedia)
               python-qpid = 0.14-11.el6_3
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]