[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Pulp-list] PostgreSQL/Django Support



I found the release note from django that talks about not supporting postgres 8.4 in django 1.8: https://docs.djangoproject.com/en/1.9/releases/1.8/#support-for-postgresql-versions-older-than-9-0

Are you aware of any actual incompatibility? Or are they not supporting postgres before 9.0, because upstream postgres doesn't support it?

This certainly isn't ideal, but I wonder if django 1.8 would happily work on postgres 8.4, and we'd just be on our own if stuff goes wrong. And obviously we couldn't use any new postgres-specific features in that case. Or maybe there actually are backward-incompatible API changes in 9.0?

Michael

On Thu, Apr 28, 2016 at 12:52 PM, Patrick Creech <pcreech redhat com> wrote:
Team,

So, it appears the 'Which verson of postgresql' to support is a little more nuanced than we
initially hoped.  Primarily, it locks us into what version of django we are using.

Currently, the plan is to support whatever postgresql is provided by default in EL6 (v8.4).  The
feedback we have received from some stakeholders is that is the path they have chosen, and taking
them and Sattelite into account, it might be nice for them not to have to explain why you need two
different versions of the same database installed.

On top of that, some of our own userbase might be installing pulp in a datacenter in which they have
already had a significant investment put into their own PostgreSQL installation.  These people would
probably like to use that database server instead of having to stand up another one.  (Setting up a
database server following compliance and HA guidelines is a huge investment, and they will probably
want to maximize the benefit they get for that investment).  Allowing the maximum compatibilty for
user scenarios will be a huge benefit for adoption, in my opinion[0].

Which leads me into this next topic, which is Django version support.  With the decision to support
PostgreSQL 8.4 (default in EL6), We effectively lower our maximum version of Django support to 1.7.
 Take also into account that the default python on EL6 is 2.6, we effectively lower the maximum
version again to 1.6.  The state of using SCL Python 2.7 will probably dictate our maximum version
here for EL6.

Another +1 to possibly using Django 1.7 with SCL Python 2.7 is that django maintains y+1
compatibility, allowing us to potentially use Django 1.8[1] in envirionments that provide postgresql
9.0 or higher.  (EL7 has 9.2 by default)  This might also have other impacts though, which have yet
to be fully researched.

With this being said, we are still open to questions/thoughts/concerns on these topics, and would
like to hear your feedback if you have any.

Thanks,
Patrick

[0]:
And, if we pay attention to how we use django models, we might be able to say we run on multiple
databases, and support whatever is supported by that Django version, thereby maximising our database
compatiblity.

[1]:
Why would we be interested in Django 1.8?  Because Django 1.8 is an LTS release.

_______________________________________________
Pulp-list mailing list
Pulp-list redhat com
https://www.redhat.com/mailman/listinfo/pulp-list


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]