[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Pulp-list] Debian repositories support in Pulp



I've recently talked with two Pulp users in #pulp who have tried to use
pulp_deb with pulp-server 2.8.0. From those conversations I know that
pulp_deb is incompatible with pulp-server 2.8+ due to changes to the
Pulp internals between 2.7-> 2.8 related to mongoengine.

Several of us have fixed these types of issues in the past in other
plugins so if someone wants to try to fix these come ask in #pulp-dev on
freenode.

It would be good to bring an up-to-date developer environment [0] when
you come. Personally, I recommend running Vagrant on a Fedora 22+ machine.

[0]:
http://pulp.readthedocs.io/en/latest/dev-guide/contributing/dev_setup.html

-Brian


On 04/28/2016 01:28 PM, Randy Barlow wrote:
> On Wed, Apr 27, 2016 at 06:14:29PM -0300, Alan Evangelista wrote:
>> Was there or is there any active development of Debian repositories support in Pulp ?
>> I see https://pulp.plan.io/issues/809 , but it seems stalled. I'd like to contribute.
> 
> Hello Alan!
> 
> There was active development from some community members, but the effort
> has been stalled for some time. If you'd like to take the project on, we
> do have a repository for Debian support and we would love to see
> contributions there:
> 
> https://github.com/pulp/pulp_deb
> 
> I am not familiar with the state of that code, but AFAIK it never was
> "completed" enough to be functional. If you are interested in taking
> this project on, hop over to #pulp on Freenode and chat with us. I'd
> love to help you get started, and we have a pretty nice Vagrant
> based development environment that makes it easier to work on Pulp.
> 
> 
> 
> _______________________________________________
> Pulp-list mailing list
> Pulp-list redhat com
> https://www.redhat.com/mailman/listinfo/pulp-list
> 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]