[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Pulp-list] PostgreSQL/Django Support



Some lessons learned form the Foreman running on RHEL6 - the SCL for the language stack, in order to keep  the project running on more distributions (RHEL6 vs. RHEL7) is a must: in Rails, the basic problem was, the old Rails version was not running on ne Ruby (comming with RHEL7) while the new Rails version was not running on the old Ruby (comming with RHEL6). That would lead for us to support two different Rails versions, which just wasn't feasible.

Running language stack from SCL brought us a big benefit supporting different os versions. In comparison, the database in SCL vs. the system one has bigger impacts, as was said in the first mail of this thread. Given the conservatism of the SQL ecosystem, I would not be that scared from the Postgres 8.4 not working at all with new Django (although it of course depends how Django developers consider backward compatibilty- however given they support other DB servers as well, I would expect they not using just the latest greates in a specific database and use some common stuff from all databases). Anyway, it's a good idea to investigate this before choosing the right versions.

Although, I don't know much about Django, so my assumption is it's not that different from the Rails in terms of how the community works (of course the Django is much better that Rails though :)

-- Ivan

On Thu, Apr 28, 2016 at 7:47 PM, Patrick Creech <pcreech redhat com> wrote:
On Thu, 2016-04-28 at 13:14 -0400, Michael Hrivnak wrote:
> I found the release note from django that talks about not supporting postgres 8.4 in django 1.8: h
> ttps://docs.djangoproject.com/en/1.9/releases/1.8/#support-for-postgresql-versions-older-than-9-0
>
> Are you aware of any actual incompatibility? Or are they not supporting postgres before 9.0,
> because upstream postgres doesn't support it?
>
> This certainly isn't ideal, but I wonder if django 1.8 would happily work on postgres 8.4, and
> we'd just be on our own if stuff goes wrong. And obviously we couldn't use any new postgres-
> specific features in that case. Or maybe there actually are backward-incompatible API changes in
> 9.0?
>

I am not aware of any real world incopatibiliity, but I am hesitant to say we should support
something outside of the dependency tree of someting we are utilizing.  Django's codebase in 1.8
could make some assumptions for it's PostgreSQL connection to be utilizing a server >= 9.0, and
could have unpredictable behavior when connecting to a PostgreSQL 8.4 server. At least by utilizing
Django 1.7 for PostgreSQL 8.4 installs, we will have predictable behaviors.  

This is pure speculation at this point, but is a reasonable assumption in my opinion.  


_______________________________________________
Pulp-list mailing list
Pulp-list redhat com
https://www.redhat.com/mailman/listinfo/pulp-list


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]