[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Pulp-list] RHEL 6 Server ISOs CDN channel problem?



Kodiak Firesmith <kfiresmith gmail com> writes:

> Hi Tyrone,
> Unfortunately the problem is ongoing.  I've just tried once more to be
> sure, it's still related to the rhel-server-6.10-x86_64-dvd.iso image
> sync.  I'm wondering if the CDN team might be able to scrutinize that ISO
> compared to other ISOs that do work, and see what makes this particular ISO
> uniquely problematic.
>

Could you please try that once more?

What happened here is that Red Hat published a new version of this ISO
(and several others) with the same filename.  This is an unusual event
and some of the publishing tools didn't cope with it correctly,
particularly with respect to CDN caching.  It meant that some clients
were still seeing the old version of the ISOs, leading to a checksum
mismatch on sync.

The issue should be resolved now, with all clients only seeing the
up-to-date content.

I've also filed https://pulp.plan.io/issues/3845 regarding the unhelpful
error messages from Pulp.

>
> On Fri, Jul 6, 2018 at 12:58 AM Tyrone Abdy <tabdy redhat com> wrote:
>
>> Is that fixed for you now?
>>
>> On 3 July 2018 at 01:21, Kodiak Firesmith <kfiresmith gmail com> wrote:
>>
>>> I've created Red Hat support case #02132814 to track this Red Hat CDN
>>> problem.
>>>
>>> On Mon, Jul 2, 2018 at 9:49 AM Kodiak Firesmith <kfiresmith gmail com>
>>> wrote:
>>>
>>>> Yay!  I love it when a problem isn't specific to my site!   I'll raise a
>>>> support ticket and see if I can't convince Red Hat GSS that there is a
>>>> problem with that CDN channel.
>>>> @redhat.com folks on this list, please feel free to reach out if you
>>>> have contacts on the Red Hat CDN side of the house and you'd like a copy of
>>>> the ticket number.
>>>>
>>>> Huge thanks to Mr. Gersting for confirming!
>>>>
>>>>  - Kodiak
>>>>
>>>> On Mon, Jul 2, 2018 at 9:42 AM David Gersting <dgersting systems wvu edu>
>>>> wrote:
>>>>
>>>>> Looks like I'm seeing the same thing with ours. It's interesting that
>>>>> the error message is blank in the exception, and that you only get the
>>>>> ISO's name.
>>>>>
>>>>> https://paste.fedoraproject.org/paste/~GoCoCFIyfH0UovVDl5zQA
>>>>>
>>>>>
>>>>> */* David Gersting
>>>>>
>>>>> UNIX/Linux System Administrator
>>>>>
>>>>> Information Technology Services
>>>>>
>>>>> West Virginia University
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> On Mon, Jul 2, 2018 at 8:44 AM Kodiak Firesmith <kfiresmith gmail com>
>>>>> wrote:
>>>>>
>>>>>> This is a classic case of:  "Is his broken for everyone or just me?"
>>>>>>
>>>>>> I'm seeing the following problem with the RHEL 6 Server ISOs Red Hat
>>>>>> CDN channel since some time ~10 days ago.  It seems like the channel is
>>>>>> broken somehow or at least something is coming down that is confusing
>>>>>> Pulp.  All other ISO channels on Red Hat CDN for RHEL 5,6,7
>>>>>> Server,Workstation all seem to work fine.
>>>>>>
>>>>>> Here's what Pulp sees:
>>>>>>
>>>>>> https://paste.fedoraproject.org/paste/EzAQRp64UkoFaXdZOkjRLg
>>>>>>
>>>>>> If anyone else could please try out this CDN channel and report back
>>>>>> with results, that would be much appreciated!
>>>>>>
>>>>>> Thanks!
>>>>>>  - Kodiak Firesmith, Pittsburgh

-- 
Rohan McGovern


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]