[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Pulp-list] Pulp 2.19.0 now Generally Available



Pulp 2.19.0 is now available, and can be downloaded from the 2.19 stable repositories:

https://repos.fedorapeople.org/repos/pulp/pulp/stable/2.19/

This release includes new features for: Pulp, RPM Support, Crane, Debian Support, Docker Support.

Upgrading
=========

The Pulp 2.19 stable repository is included in the pulp repo files:
    https://repos.fedorapeople.org/repos/pulp/pulp/fedora-pulp.repo for Fedora
    https://repos.fedorapeople.org/repos/pulp/pulp/rhel-pulp.repo for RHEL 7

After enabling the pulp-stable repository, you'll want to follow the standard upgrade path
with migrations:

$ sudo systemctl stop httpd pulp_workers pulp_resource_manager pulp_celerybeat pulp_streamer goferd
$ sudo yum upgrade
$ sudo -u apache pulp-manage-db
$ sudo systemctl start httpd pulp_workers pulp_resource_manager pulp_celerybeat pulp_streamer goferd

The pulp_streamer and goferd services should be omitted if those services are not installed.

Issues Addressed
================

Pulp
    3896    pulp_docker importer discards relevant exception details
    4228    Update docs with instructions to install Mongo DB 3.x
    4405    Pulp 2.19master nightly ci regression at test_modularity.py
    4425    It's possible to create a duplicate login if name is different

RPM Support
    2729    pulp_user_metadata is ignored during ISO import
    4477    Duplicated empty collections are published with subsequent sync/publish of modular errata
    4518    Modules are not copied during recursive copy of modular errata
    4262    Pulp raises an unhelpful IOError when it fails to download a repo metadata file
    4267    force_full is not honored for distribution units
    4373    Applicability Exception: Repository matching query does not exist.
    4397    Unable to sync 3 SLES Update repositories
    4419    Publish modulemd/productid when generate_sqlite is set to true
    4476    pulp_rpm.handlers.rpm does not work with Python 2.4
    4541    Repository publishing duplicates RPM files under Packages and Packages/<LETTER> structure
    4371    Document how to use the newly added recursive_conservative
    3740    Implement modularity content dependency solving
    4527    Improve performance of rpm duplicate nevra check

Crane
    4227    Crane 3.2 to 3.3 - _javascript_ error

Debian Support
    4008    python-debpkgr does not structure Repositories correcly (in some case)
    4148    Fix flake8 violations
    4176    from_file() and from_metadata() create different data structures in mongodb
    4546    Safely select packages to symlink in components

Docker Support
    4328    fsLayers error during sync
    4384    Pulp Crane not returning correct headers

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]