[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Pulp-list] rpm publication problem pulp3




On 18/06/19 16:07, Dennis Kliban wrote:
On Tue, Jun 18, 2019 at 9:05 AM Juan Cabrera <juan cabrera unamur be> wrote:

Hi all,

Until now I was using the "One shot upload" to upload the packages.

If I understand correctly, with "One shot upload" it is not possible to add the same package to a different repository as a rise condition is set:

 if not created:

        raise OSError('RPM package {} already exists.'.format(pkg.filename))


This makes sense. Once an RPM is in Pulp, you should use the Repository Version Create API[0] to add it to another repository.


Thanks Dennis, I will use this.


 

So I try the long way. In this case I can upload the packages (artifacts) and create contents but there is a problem when I what to create a publication.

Please file an issue about this problem[1]. You should not be able to create a duplicate RPM package. It looks like Pulp 3 is not validating that all required fields are being supplied to the RPM create API[1].

I created the issue https://pulp.plan.io/issues/4987


--

Juan CABRERA
Correspondant informatique
Département de Mathématiques

T. 081724919
juan cabrera unamur be
http://staff.unamur.be/jbcabrer

Université de Namur ASBL
Rue de Bruxelles 61 - 5000 Namur
Belgique

Let’s respect the environment together.
Only print this message if necessary!


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]