[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Pulp-list] create remote to redhat on pulp 3



You need to make sure that the following services are running: pulp-resource-manager, pulp-worker 0, pulp-worker 1 (at least 1 worker is needed).

On Thu, Jun 20, 2019 at 4:11 PM Bin Li (BLOOMBERG/ 120 PARK) <bli111 bloomberg net> wrote:
I installed the latest version of component. No more errors when try to sync the repo but the task is in waiting state forever. Any idea what I should check?

"versions": [
{
"component": "pulpcore",
"version": "3.0.0rc3.dev0"
},
{
"component": "pulpcore-plugin",
"version": "0.1.0rc3.dev0"
},
{
"component": "pulp_rpm",
"version": "3.0.0b4.dev0"
}



From: dkliban redhat com At: 06/18/19 13:42:01
To: Bin Li (BLOOMBERG/ 120 PARK )
Cc: pulp-list redhat com
Subject: Re: [Pulp-list] create remote to redhat on pulp 3

This issue has now been resolved and a fix is available on master branch of pulpcore-plugin[0].



On Wed, Jun 12, 2019 at 1:51 PM Dennis Kliban <dkliban redhat com> wrote:
There is an open issue about this[0]. I recommend clicking the watch button so you get notifications about it. We should be fixing this soon.


On Wed, Jun 12, 2019 at 1:42 PM Bin Li (BLOOMBERG/ 120 PARK) <bli111 bloomberg net> wrote:

I was not able to sync a protected repo from redhat. The host running pulp 3 subscribes to redhat directly.

I first tried to use the following to create remote:
{
"name": "rhel-x86_64-server-7",
"ssl_ca_certificate": "/etc/rhsm/ca/redhat-uep.pem",
"ssl_client_certificate": "/etc/pki/consumer/cert.pem",
"ssl_client_key": "/etc/pki/consumer/key.pem",
"ssl_validation": true,
"proxy_url": "http://proxy:80",
"download_concurrency": 1,
"policy": "immediate"
}

Remote was created but I got errors "Jun 12 12:51:43 ip-1-76-158-244 rq[19389]: pulp: rq.worker:ERROR: ssl.SSLError: [PEM: NO_START_LINE] no start line (_ssl.c:3626)" when I tried to sync with http POST :24817${REMOTE_HREF}sync/ repository=$REPO_HREF

Then I tried to converted the pem file to a json format
{
"name": "rhel-x86_64-server-7",
"ssl_ca_certificate": "-----BEGIN CERTIFICATE-----\nMIIG/TCCBOWgAwIBAgIBNzANBgkqhkiG9w0BAQUFADCBsTELMAkGA1UEBhMCVVMx\nFzAVBg
...
"ssl_client_certificate": "-----BEGIN CERTIFICATE-----\nMIIMojCCCoqgAwIBAgIISqmnKnJ9sEowDQ
...
"ssl_client_key": "-----BEGIN RSA PRIVATE KEY-----\nMIIJKQIBAAKCAgEAuujl5HxnIDTSOemZOyH3Jr5xxgrc1rCee
...
"ssl_validation": true,
"proxy_url": "http://proxy:80",
"download_concurrency": 1,
"policy": "immediate"
}

I got this error when I tried to sync repo with the remote:
Jun 12 12:07:57 ip-1-76-158-244 rq[19389]: ssl.SSLError: [SSL] PEM lib (_ssl.c:3503)


What is the correct json input for creating a remote to redhat? How do I troubleshoot the sync issue? Thanks for your help.
_______________________________________________
Pulp-list mailing list
Pulp-list redhat com
https://www.redhat.com/mailman/listinfo/pulp-list


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]