[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Rdo-list] Why use yum priority in rdo-release repo file?



On 06/20/2013 09:30 AM, Sandro "red" Mathys wrote:
> Even though RDO is supposed to always being ahead of RHEL and EPEL, it enforces a higher priority (lower priority=N) than the default. Why?

So yes this is debatable.
y-p-p is used with the RHOS product to give precedence over EPEL.
I.E. even though EPEL is not required there, con existence is supported.

Now RDO requires EPEL so again y-p-p gives us the flexibility for RDO to override EPEL.
Now whether this is actually required at present is not obvious.

We could retain the flexiblity while avoiding problems with y-p-p
by keeping the overlapping set as small as possible.

wrt puppet, I'm not sure why it's there TBH.
EPEL has 2.6.18-3 while puppet-2.6.18-2 is in the RDO repo.
I've asked around a little and will probably just remove
puppet from the RDO repo, which will fix your immediate problem.

I also see django14 in the RDO grizzly repos.
IIRC there were issues with the provides and requires in horizon and django
that required this package be present in RDO with y-p-p giving
precedence to it. Now there are recent changes in EPEL with Django14
being pushed there. Matthias could you remove Django14 from the
RDO repo if possible thus not having to worry about y-p-p for it at least?

> Enforcing priorities should really only ever happen if absolutely necessary and will often cause pain to users.
> 
> For example I'm trying to manage my RDO installation with Puppet but EPEL and RDO only have Puppet 2.6 which is EOL and it has been decided that puppet-openstack will no longer support it effective immediately. But to install puppet 3.2 from puppetlabs' repo, I first have to scrap the priority from RDO's repo file manually.
> 
> As a (former) developer for Packstack I understand it requires a specific Puppet version but I think we all agree most (non proof of concept) installations are not using Packstack to set up or maintain their OpenStack cloud.

Looking at packstack, it installs y-p-p if epel-release is installed
(which it will be by default for RDO).
Again the intention here is to allow these "openstack" repos to override EPEL.
Maybe we should change that logic to only installing y-p-p if RHOS,
as opposed to RDO was being used? Also we'd have packstack setting the
priority in the repo files to actually enable y-p-p (which could already have been installed).

Anyway given the package removals mentioned about,
I don't see an immediate need to adjust packstack.

thanks,
Pádraig.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]