[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Rdo-list] Puppet glusterers unite



James Shubin <jshubin redhat com> writes:
> On Wed, 2014-04-09 at 17:04 -0400, John Eckersberg wrote:
>> Good point, I only checked by declaring gluster::api.  When I declare
>> gluster::mount::base instead, I get:
>> 
>> Error: Could not retrieve catalog from remote server: Error 400 on
>> SERVER: Invalid tag "::gluster::api"
>> at /usr/share/packstack/modules/gluster/manifests/mount/base.pp:55 on
>> node compute.example.org
>> 
>> Changing the second parameter of ensure_resource from '::gluster::api'
>> to 'gluster::api' seems to make it work, for better or worse.
>
> Sounds like you're using Puppet < 3.x Can you confirm?
> I think the leading :: is recommended for 3.x, but I should test if it's
> required.

This is with:

puppet-3.2.4-3.el6_5.noarch
puppet-server-3.2.4-3.el6_5.noarch


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]