[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Rdo-list] Puppet 3.5.1 breaks RDO Foreman Installs



Hi Brad,

You're best off limiting to puppetversion < 3.5 just to be safe. There are a large number of bugs fixed in scoping (that were features before) in Puppet 3.5. You probably need functional deployment now, so it's best to just cut off the flow of 3.5 bugs until you've had time to refactor for the new puppet release.

Best Regards,
Matthew Mosesohn



On Tue, Apr 22, 2014 at 5:20 PM, Brad P. Crochet <brad redhat com> wrote:
Pupppet Labs released into their repo (http://yum.puppetlabs.com) a
3.5.1 version sometime last week.
This version renders the Foreman install inoperable. Thanks to a catch
by Crag, it was discovered.
I have tested both 3.2.4 and 3.4.3 (using yum-plugin-versionlock), and
it works with those versions.

We currently have in openstack-foreman-installer:

Requires: puppet >= 2.7

It seems we have a number of options to fix this:

1) Make the current Astapor codebase compatible with 3.5.1, hopefully
without breaking current compatibility.
2) Require a version <= 3.4.3
3) Remove the puppetlabs repos from rdo-release, and rely on the
puppet from EPEL/Fedora.

I would say these options are not necessarily mutually exclusive.

This affects both Havana and Icehouse.

Brad

_______________________________________________
Rdo-list mailing list
Rdo-list redhat com
https://www.redhat.com/mailman/listinfo/rdo-list



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]