[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Rdo-list] Glance problems...



On 23/04/14 16:40 -0700, Erich Weiler wrote:
Hi Y'all,

I was able to set up RDO Openstack just fine with Icehouse RC1, and then I wiped it out and am trying again with the official stable release (2014.1) and am having weird problems. It seems there were many changes between this and RC1 unless I'm mistaken.

The main issue I'm having now is that I can't seem to create the glance database properly, and I was able to do this before no problem. I do:

$ mysql -u root -p
mysql> CREATE DATABASE glance;
mysql> GRANT ALL PRIVILEGES ON glance.* TO 'glance'@'localhost' \
IDENTIFIED BY 'GLANCE_DBPASS';
mysql> GRANT ALL PRIVILEGES ON glance.* TO 'glance'@'%' \
IDENTIFIED BY 'GLANCE_DBPASS';

(Obviously 'GLANCE_DBPASS' is replaced with the real password).

Then:

su -s /bin/sh -c "glance-manage db_sync" glance

And it creates the 'glance' database and only one table, "migrate_version". I can't get it to create the rest of the tables it needs. I've tried also:

openstack-db --init --service glance --password GLANCE_DBPASS

And that returned success but in reality nothing happened... Any idea what's going on?

In the api.conf and registry.conf the correct database credentials are listed, and I can connect to the database as the mysql glance user on the command line just fine using those credentials.

Something wrong is happening with glance's database initialization, as
you already mentioned. Does it throw an error?

Could you please try running just:
$ glance-manage db_sync

[snip]

--
@flaper87
Flavio Percoco

Attachment: pgp2nU5OjVTmn.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]