[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Rdo-list] python-kombu 1.1.3 is not recommended version of Icehouse



On 05/22/2014 08:37 AM, Koji IIDA wrote:
> Hi,
> 
> I'm just installed RDO Icehouse on my CentOS 6.5 box using packstack.
> I found that the version of python-kombu does not satisfy the
> requirement of Icehouse.
> 
> 
> python-kombu installed by packstack:
>   python-kombu.noarch	1.1.3-2.el6	@openstack-icehouse
> 
> nova (Icehouse ver) requirement.txt:
>   kombu>=2.4.8  (*)
> 
> So, I want to update kombu to version 2.4.8 or above.
> 
> Any suggestions?

Note the upstream requirements are often not the same as distro requirements
due to varying version combinations and backports.

The particular reason kombu requirement was updated upstream
was to cater for newer msgpack modules. However the EPEL version
of python-msgpack should not have this issue with python-kombu.
Details in https://pad.lv/1134575

So does this cause another issue for you?

Note EPEL7 is at v2.5.16 (and rawhide is at v3.0.15)
so in case it's useful to you I've just rebuilt but not tested v2.5.16
for el6 by doing:

  fedpkg clone python-kombu
  git checkout epel7
  fedpkg --dist=el6 scratch-build

Result is at (for a while):

  http://koji.fedoraproject.org/koji/taskinfo?taskID=6875634

thanks,
Pádraig.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]