[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Rdo-list] python-kombu 1.1.3 is not recommended version of Icehouse



Hi,

Thank you for good suggestions.

> The particular reason kombu requirement was updated upstream
> was to cater for newer msgpack modules. However the EPEL version
> of python-msgpack should not have this issue with python-kombu.
> Details in https://pad.lv/1134575
>
> So does this cause another issue for you?

There is benchmark tool for oslo.messaging introduced at last Atlanta
summit.

Etherpad:
https://etherpad.openstack.org/p/juno-oslo.messaging-amqp-1.0

Code:
https://github.com/grs/ombt


When I tried this benchmarking tool on my RDO box (kombu 1.1.3-2), I got
a poor throughtput (7.7 request/sec). But just updating kombu to 2.5.8,
I got a better throughput (91 reuest/sec).

I don't know why kombu 1.1.3-2 results such a poor performance.

thanks,
Koji

----
### kombu 1.1.3-2
$ ./ombt.py --calls 100 --conf rpc_backend rabbit --conf rabbit_host
192.168.101.33 --conf rabbit_password guest
INFO:oslo.messaging._drivers.impl_rabbit:Connected to AMQP server on
192.168.101.33:5672
INFO:oslo.messaging._drivers.impl_rabbit:Connected to AMQP server on
192.168.101.33:5672
INFO:oslo.messaging._drivers.impl_rabbit:Connected to AMQP server on
192.168.101.33:5672
INFO:oslo.messaging._drivers.impl_rabbit:Connected to AMQP server on
192.168.101.33:5672
Call 10 of 100 completed
Call 20 of 100 completed
Call 30 of 100 completed
Call 40 of 100 completed
Call 50 of 100 completed
Call 60 of 100 completed
Call 70 of 100 completed
Call 80 of 100 completed
Call 90 of 100 completed
Call 100 of 100 completed
{'latency': {'count': 100, 'min': 123.36111068725586, 'max':
258.3320140838623, 'average': 129.59874868392944, '_sum_of_squares':
1699774.5017536662, 'std_deviation': 14.209481239522995, 'total':
12959.874868392944}, 'throughput': 7.7150386788072778, 'calls': 100}
----

----
### kombu-2.5.8-1.el6
$ ./ombt.py --calls 100 --conf rpc_backend rabbit --conf rabbit_host
192.168.101.33 --conf rabbit_password guest
INFO:oslo.messaging._drivers.impl_rabbit:Connected to AMQP server on
192.168.101.33:5672
INFO:oslo.messaging._drivers.impl_rabbit:Connected to AMQP server on
192.168.101.33:5672
/usr/lib/python2.6/site-packages/amqp/channel.py:608:
DeprecationWarning: auto_delete exchanges has been deprecated
  'auto_delete exchanges has been deprecated'))
INFO:oslo.messaging._drivers.impl_rabbit:Connected to AMQP server on
192.168.101.33:5672
INFO:oslo.messaging._drivers.impl_rabbit:Connected to AMQP server on
192.168.101.33:5672
Call 10 of 100 completed
Call 20 of 100 completed
Call 30 of 100 completed
Call 40 of 100 completed
Call 50 of 100 completed
Call 60 of 100 completed
Call 70 of 100 completed
Call 80 of 100 completed
Call 90 of 100 completed
Call 100 of 100 completed
{'latency': {'count': 100, 'min': 6.4032077789306641, 'max':
111.25898361206055, 'average': 10.875468254089355, '_sum_of_squares':
22480.778639419441, 'std_deviation': 10.321432877681714, 'total':
1087.5468254089355}, 'throughput': 91.755911089409807, 'calls': 100}
----

(2014/05/22 22:27), Pádraig Brady wrote:
> On 05/22/2014 08:37 AM, Koji IIDA wrote:
>> Hi,
>>
>> I'm just installed RDO Icehouse on my CentOS 6.5 box using packstack.
>> I found that the version of python-kombu does not satisfy the
>> requirement of Icehouse.
>>
>>
>> python-kombu installed by packstack:
>>   python-kombu.noarch	1.1.3-2.el6	@openstack-icehouse
>>
>> nova (Icehouse ver) requirement.txt:
>>   kombu>=2.4.8  (*)
>>
>> So, I want to update kombu to version 2.4.8 or above.
>>
>> Any suggestions?
> 
> Note the upstream requirements are often not the same as distro requirements
> due to varying version combinations and backports.
> 
> The particular reason kombu requirement was updated upstream
> was to cater for newer msgpack modules. However the EPEL version
> of python-msgpack should not have this issue with python-kombu.
> Details in https://pad.lv/1134575
> 
> So does this cause another issue for you?
> 
> Note EPEL7 is at v2.5.16 (and rawhide is at v3.0.15)
> so in case it's useful to you I've just rebuilt but not tested v2.5.16
> for el6 by doing:
> 
>   fedpkg clone python-kombu
>   git checkout epel7
>   fedpkg --dist=el6 scratch-build
> 
> Result is at (for a while):
> 
>   http://koji.fedoraproject.org/koji/taskinfo?taskID=6875634
> 
> thanks,
> Pádraig.
> 
> 




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]