[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Rdo-list] python-kombu 1.1.3 is not recommended version of Icehouse



On 05/25/2014 10:19 AM, Belmiro Moreira wrote:
> Hi,
> in our setup we are using Rabbitmq clustered with mirrored queues.
> Is this the recommended kombu version for this configuration?

I presume by "this" you mean v2.5.16 I suggested syncing up between el6 and el7.
There doesn't seem to be any specific mention of "clustering", "HA" or "mirrored"
in the kombu or amqp changelogs, though I did notice this issue that was
worked around in oslo.messaging: https://review.openstack.org/#/c/76686/
Possibly related to that is improved support for heartbeat in python-amqp-1.4.0

Anyway the OpenStack upstream requirements for both Havana and Icehouse are:

$:requirements (stable/icehouse)$ grep -E "(amqp|kombu)" global-requirements.txt
amqplib>=0.6.1
kombu>=2.4.8

So bumping to 2.5.16 shouldn't negatively impact anything I think.

thanks,
Pádraig.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]