[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Rdo-list] When will RDO for Juno release be officially available?



upps :-) thx again.

So, as conclusion after any yum upgrade we need to run packstack again and do a neutron-db-manage like:

[root controller ~(keystone_admin)]# neutron-db-manage --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/plugin.ini upgrade head
INFO  [alembic.migration] Context impl MySQLImpl.
INFO  [alembic.migration] Will assume non-transactional DDL.
INFO  [alembic.migration] Running upgrade juno -> c00e3802ef7, empty message

and openstack-service restart

right?

Now I've a small problem with the vnc console, it doesn't work anymore, in the vnc proxy log I see:

2014-10-12 06:08:46.583 23108 INFO nova.console.websocketproxy [req-83b79c9e-9f2f-467e-87fe-b73d589b9532 None] connecting to: <controller-ip>:5900
2014-10-12 06:08:56.170 23106 INFO nova.console.websocketproxy [-] <vpn-server-ip>: ignoring empty handshake

cirros needs a long time to come up, due to "failed to get instance-id of datasource": ???

cirros-ds 'net' up at 60.74
checking http://169.254.169.254/2009-04-04/instance-id
failed 1/20: up 60.75. request failed
failed 2/20: up 65.76. request failed
....
failed 19/20: up 122.76. request failed
failed 20/20: up 125.76. request failed
failed to read iid from metadata. tried 20
no results found for mode=net. up 128.76. searched: nocloud configdrive ec2
failed to get instance-id of datasource
Starting dropbear sshd: generating rsa key... generating dsa key... OK
=== system information ===
Platform: Fedora Project OpenStack Nova

Tested that with CentOS image too, it seems to be a routing problem:
cloud-init[778]: 2014-10-17 09:39:57,539 - url_helper.py[WARNING]: Calling 'http://169.254.169.254/2009-04-04/meta-data/instance-id' failed [119/120s]: request error [[Errno 113] No route to host]
cloud-init[778]: 2014-10-17 09:40:02,544 - DataSourceEc2.py[CRITICAL]: Giving up on md from ['http://169.254.169.254/2009-04-04/meta-data/instance-id'] after 124 seconds
cloud-init[778]: 2014-10-17 09:40:05,552 - url_helper.py[WARNING]: Calling 'http://20.0.0.1//latest/meta-data/instance-id' failed [3/120s]: request error [[Errno 113] No route to host]
loud-init[778]: 2014-10-17 09:42:00,666 - url_helper.py[WARNING]: Calling 'http://20.0.0.1//latest/meta-data/instance-id' failed [118/120s]: request error [[Errno 113] No route to host]
cloud-init[778]: 2014-10-17 09:42:05,672 - DataSourceCloudStack.py[CRITICAL]: Giving up on waiting for the metadata from ['http://20.0.0.1//latest/meta-data/instance-id'] after 123 seconds
cloud-init[960]: Cloud-init v. 0.7.5 running 'modules:config' at Fri, 17 Oct 2014 09:42:07 +0000. Up 323.40 seconds.
Thanks!
-Arash

On Fri, Oct 17, 2014 at 10:38 AM, Ihar Hrachyshka <ihrachys redhat com> wrote:
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

You've missed 'head' at the end of the command.

On 17/10/14 10:36, Arash Kaffamanesh wrote:
> .. wenn I run: [root controller~(keystone_admin)]#
> neutron-db-manage --config-file /etc/neutron/neutron.conf
> --config-file /etc/neutron/plugin.ini upgrade
>
> I'm getting:
>
> You must provide a revision or relative delta
>
> any ideas?
>
> Thx -Arash
>
> On Fri, Oct 17, 2014 at 10:34 AM, Arash Kaffamanesh
> <ak cloudssky com <mailto:ak cloudssky com>> wrote:
>
> Ihar, thanks, much appreciated. When I run:
>
>
> On Fri, Oct 17, 2014 at 10:13 AM, Ihar Hrachyshka
> <ihrachys redhat com <mailto:ihrachys redhat com>> wrote:
>
> On 16/10/14 18:12, Arash Kaffamanesh wrote:
>> Just let you know, I did a yum upgrade on controller and compute
>> nodes and the packages was upgraded to rc2 and rc3 packages,
>> after that neutron didn't work on controller and I'd only to
>> re-run packstack and reboot my instances and I was more than
>> lucky :-)
>"
> I suspect this is because you need to run db migration steps after
> each update till the final release, otherwise you loose some db
> migration steps, and service crashes.
>
> # neutron-db-manage \ --config-file /etc/neutron/neutron.conf \
> --config-file /etc/neutron/plugin.ini upgrade head
>
> /Ihar
>
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG/MacGPG2 v2.0.22 (Darwin)

iQEcBAEBCgAGBQJUQNV9AAoJEC5aWaUY1u57PHkH/0CdZGaGL0KFuAoA1Wp85JvO
TD43ZfCgfhx4P9UxT96FpIOw7X4/QrD0Z/vrKn27+8yF1yHZTUZhG4zBZibgyjEu
kEFeu+w43+0Ckfe/m1Wz0KI/SLkHcfgsiCXp6kfqvQEdjrriFrY3k1gD++dGzgEI
MfMTNcliXimdZ1RR5EE9SdtvviZW8xLLmBpFClEzTKA9mPVaTQOlSu/SSVXv2v5Z
ALWsshnN7X1Fb/Za8/VsJKQORO4EhZUB4zbL2jXd96tGgs7XoJeYpqrJUqAiUNVl
nKVqGQHz5F8QnSzLkos8T3fWo7N0SMDP7EHqY9Ed2f8ZQrXYsngeD2zWcd8hhkw=
=NheQ
-----END PGP SIGNATURE-----


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]