[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Rdo-list] Devstack - why it uninstalls python-virtualenv?



On 03/Mar/2015 .::. 14:03, Kaul, Yaniv wrote:
> When I'm installing DevStack, it performs the following:
> ++ FORCE_FIREWALLD=False
> ++ [[ rhel7 =~ (f20) ]]
> ++ uninstall_package python-virtualenv
> ++ is_ubuntu
> ++ [[ -z rpm ]]
> ++ '[' rpm = deb ']'
> ++ is_fedora
> ++ [[ -z CentOS ]]
> ++ '[' CentOS = Fedora ']'
> ++ '[' CentOS = 'Red Hat' ']'
> ++ '[' CentOS = CentOS ']'
> ++ sudo yum remove -y python-virtualenv
> Loaded plugins: fastestmirror, rhnplugin
> This system is receiving updates from RHN Classic or Red Hat Satellite.
> Resolving Dependencies
> --> Running transaction check
> ---> Package python-virtualenv.noarch 0:1.10.1-2.el7 will be erased
> --> Finished Dependency Resolution
> 
> Dependencies Resolved
> 
> ================================================================================
> Package                  Arch          Version              Repository    Size
> ================================================================================
> Removing:
> python-virtualenv        noarch        1.10.1-2.el7         @base        1.6 M
> 
> Transaction Summary
> ================================================================================
> Remove  1 Package
> 
> Installed size: 1.6 M
> Downloading packages:
> Running transaction check
> Running transaction test
> Transaction test succeeded
> Running transaction
>   Erasing    : python-virtualenv-1.10.1-2.el7.noarch                        1/1
>   Verifying  : python-virtualenv-1.10.1-2.el7.noarch                        1/1
> 
> Removed:
>   python-virtualenv.noarch 0:1.10.1-2.el7
> 
> 
> ...
> ++ pip_install virtualenv
> +++ set +o
> +++ grep xtrace
> ++ local 'xtrace=set -o xtrace'
> ++ set +o xtrace
> ++ sudo -H http_proxy= https_proxy= no_proxy= /bin/pip install virtualenv
> Requirement already satisfied (use --upgrade to upgrade): virtualenv in /usr/lib/python2.7/site-packages
> ...
> 
> 
> Only to complain later:
> +++ mktemp -d tmp-venv-XXXX
> ++ TMP_VENV_PATH=tmp-venv-uUwo
> ++ virtualenv tmp-venv-uUwo
> /opt/stack/tools/build_wheels.sh: line 57: virtualenv: command not found
> +++ err_trap
> 
> 
> WHAAAAT?
> Y.

Hi Yaniv,

I think you should take a look at this change [1].

Moreover, the project has started to purge all the python libraries installed
from the distros, as much as possible, and they should now fall back to the
pypi versions.

So I think your issue is a bug caused by the latest changes related to what I
wrote above...

Hope it helps you to understand.

[1] - https://review.openstack.org/#/c/155710/

Best Regards, Gaël.

-- 
Gaël Chamoulaud
Openstack Engineering
Mail: [gchamoul|gael] at redhat dot com
IRC: strider/gchamoul (Red Hat), gchamoul (Freenode)
GnuPG Key ID: 7F4B301
C75F 15C2 A7FD EBC3 7B2D CE41 0077 6A4B A7F4 B301

Freedom...Courage...Commitment...Accountability

Attachment: pgpNNHj0NV9Vs.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]