[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Rdo-list] [RDO-Manager] IBM H-Chassis install bare metal



Thanks for responding.

That part I understand and have that working right.  The issue I am having is configuring RDO Manager/Ironic to work.  

In the undercloud.conf file, you specify the local interface.  This seems to be used for both PXE boot and IPMI operations.  When the undercloud is installed, the networking is not being configured correctly.  If the tagged interface isn't set up correctly, I lose access to the AMM and subsequently the IMM of the individual blade.

If I could get Ironic to not perform the IPMI operations and I have to reboot manually, that would be fine but I don't seem to see how to do that in the documentation.

Dave

-----Original Message-----
From: Marius Cornea [mailto:marius remote-lab net] 
Sent: Monday, November 9, 2015 11:26 AM
To: David Simmons <dsimmons krozak com>
Cc: rdo-list redhat com
Subject: Re: [Rdo-list] [RDO-Manager] IBM H-Chassis install bare metal

Hi,

If I understand it correctly you could set up the undercloud 1G port as trunk, use untagged frames for management and tagged for the Chassis Internal Network VLAN.

Here are some instructions to set up a vlan tagged interface:
https://docs.fedoraproject.org/en-US/Fedora/18/html/System_Administrators_Guide/s2-networkscripts-interfaces_802.1q-vlan-tagging.html

Thanks

On Mon, Nov 9, 2015 at 3:45 PM, David Simmons <dsimmons krozak com> wrote:
> Hi,
>
> I am installing RDO via RDO-Manager on a set of IBM H-Chassis blades.  
> I need to configure the networking to perform the IPMI operations and 
> PXE boot the overcloud nodes.  The problem I am trying to solve is to 
> get the chassis AMM to correctly route the IPMI/PXE operations to the 
> blades.  The IBM chassis requires all IPMI networking to use a VLAN 
> that has  been specified as the Chassis Internal Network.  I have 
> installed the undercloud on on blade on CentOS 7 and have been able to interact with the AMM and the blade
> IMMs on a vlan.   Where I am running into problems is when the undercloud
> configuration occurs I am no longer able to interact on the specified 
> VLAN and lose access to the Chassis AMM.
>
> On each blade I have 4 network ports.  2 1G and 2 10G network 
> switches.  I have installed CentOS on the undercloud and use 1  1G 
> port as the management.  I have specified a 10G switch as the PXE/Management network.
> In the undercloud.conf file the 10G port is the port I have specified 
> as the local interface.
>
> To use the IPMI interface it has to tag all packets with the Chassis 
> Internal Network VLAN.  Are there any configuration tips that I can follow?
>
> Thanks,
>
> David Simmons
>
> _______________________________________________
> Rdo-list mailing list
> Rdo-list redhat com
> https://www.redhat.com/mailman/listinfo/rdo-list
>
> To unsubscribe: rdo-list-unsubscribe redhat com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]