[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [rdo-list] tunneling to Horizon



On 10/23/2017 12:21 PM, James LaBarre wrote:
> On 10/19/2017 02:14 PM, Wesley Hayutin wrote:
>>
>>
>> On Wed, Oct 18, 2017 at 4:37 PM, James LaBarre <jlabarre redhat com
>> <mailto:jlabarre redhat com>> wrote:
>>
>>     I *might* (emphasize "might") have reached the Horizon server/desktop,
>>     but now Firefox will give the error:
>>
>>     ===================================================
>>
>>     An error occurred during a connection to localhost:8080. SSL
>>     received a
>>     record that exceeded the maximum permissible length. Error code:
>>     SSL_ERROR_RX_RECORD_TOO_LONG
>>
>>     ===================================================
>>
>>     Mozilla's help page suggests this is a problem with the certificate on
>>     the server side.  Now, since I presume the certificate was
>>     generated bt
>>     quickstart (I didn't generate one myself) I would guess something is
>>     wrong in the configuration
>>
>>     _______________________________________________
>>     rdo-list mailing list
>>     rdo-list redhat com <mailto:rdo-list redhat com>
>>     https://www.redhat.com/mailman/listinfo/rdo-list
>>     <https://www.redhat.com/mailman/listinfo/rdo-list>
>>
>>     To unsubscribe: rdo-list-unsubscribe redhat com
>>     <mailto:rdo-list-unsubscribe redhat com>
>>
>>
>>
>> Hrm, 
>> That kind of seems like the issue we have doc'd in
>> James, that kind of sounds like the issue
>> we doc'd in https://docs.openstack.org/tripleo-quickstart/latest/accessing-undercloud.html#access-via-the-tripleo-ui
>>
>> Please have a look and let us know.
>>
> So I tried connecting to that Port 3000 as it shows on the link above. 
> Tried connecting from my own laptop, pointing to the host system for the
> TripleO cluster.  Also tried from the host system pointing to the
> undercloud IP (cannot see the undercloud IP from my laptop). 
> 
> I *do* get a blank root directory of I just browse to the undercloud VM
> (no port or sub-directories).
> 
> 
> 
> 
> 
> _______________________________________________
> rdo-list mailing list
> rdo-list redhat com
> https://www.redhat.com/mailman/listinfo/rdo-list
> 
> To unsubscribe: rdo-list-unsubscribe redhat com
> 
Sorry for the slow/late reply on this.  There is a bug right now for
just the TripleO-UI tunneling wherein the SSH tunnel doesn't get written
properly. https://launchpad.net/bugs/1722674 I put up a patch and so did
Sagi:

https://review.openstack.org/#/c/511143/1

Both work for me in solving the tunneling issue, but then there is
another issue wherein the TripleO-UI config doesn't get written properly
if the Quickstart setup is SSL, which it is by default (and honestly I
don't know how to disable). https://bugs.launchpad.net/tripleo/+bug/1725115

At the bottom of the /etc/systemd/system/ssh-tunnel.service tunnel there
is two lines that should help hitting horizon:
   -L 0.0.0.0:8181:overcloud.localdomain:80 \
   -L 0.0.0.0:8443:overcloud.localdomain:443
modify as necessary.

-J




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]