[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [redhat-ccm-list] Can not login into the site



On Thursday 20 November 2003 10:36 pm, Randy Graebner wrote:
> Also, check to make sure that the cookie is being set correctly on
> your browser.

I second that.

If your browser is Mozilla (or if you can test with Mozilla), you
can go to 
  Edit / Preferences / Privacy & Security / Cookies / Manage Stored Cookies

(Another way to do this is via Tools / Cookie Manager / Manage Stored Cookies.)

See if there is a cookie called "ad_user_login" for the site you are
testing.

Another way to do this is to temporarily replace your Tomcat (or
whatever it is you are using) with the following simple "web server":


#!/usr/bin/perl

use IO::Socket;

$port = 9000;

$server = IO::Socket::INET->new(LocalPort => $port,
                                Type      => SOCK_STREAM,
                                Reuse     => 1,
                                Listen    => 10)
    or die "Couldn't be a tcp server on port $port: $ \n";

while ($client = $server->accept()) {
    print "Connection accepted.\n";
    while ($line= <$client>) {
        last if $line =~ /^\s*$/;
        print $line;
    }
    print $client "HTTP/1.0 200 OK\n";
    print $client "Content-Type: text/plain\n\n";
    print $client "OK\n";
    $client->close();
    print "\n";
}

# ====================================================================


So, say your site is running on http://example.com:9000/.  Stop your
servlet container, put the above script into /tmp/http_server.pl or
some such and start it like so:

$ perl /tmp/http_server.pl

Now point your browser to http://example.com:9000/

You should see something similar to the following on your console:

| $ perl /tmp/http_server.pl
| Connection accepted.
| GET / HTTP/1.1
| Host: example.com:9000
| User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020607
| Accept: text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,video/x-mng,image/png,image/jpeg,image/gif;q=0.2,text/css,*/*;q=0.1
| Accept-Language: en-us, ru;q=0.66, en;q=0.33
| Accept-Encoding: gzip, deflate, compress;q=0.9
| Accept-Charset: ISO-8859-1, utf-8;q=0.66, *;q=0.66
| Keep-Alive: 300
| Connection: keep-alive
| Cookie: ad_user_login=23!1154005324631!hLYmBPqe6thhl79FgldPFg==


If you don't have the "Cookie" header, you nailed down your problem.




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]