[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: can't dial out from Linux



Since minicom doesn't seem to be talking to your modem, check to see
that the /dev/modem link points to the right serial port. cua0 is com1,
cua1 is com2, etc.

-----Original Message-----
From: dja genesis mclean org [mailto:dja genesis mclean org]
Sent: Wednesday, 7 October 1998 1:08
To: redhat-install-list redhat com
Subject: can't dial out from Linux


Hi Linuxites!

I am a newbie with a problem that has been there since I installed RH
5.1
on my Intel Pentium II a few weeks ago: I can't get Linux to dial out
using the built-in modem.  Would anyone like to try their hand at this
riddle?

* The modem type is  56K ITU v.90
* The modem dials fine from WINDOWS 98, it allows me to surf the net,
run ws-ftp, etc.
* When I run netcfg from X-windows, I go through all the expected steps
and
netfcg appears to accept the entry.  When I click on "activate" in the 
Interfaces window (with ppp0 highlighted), the status for that line
switches
to "active" but no dialing occurs.
* When I run minicom, it tells me that the modem is initialized, and
allows
me to go through the sequence for dialing, but I don't hear any tones,
and it
simply counts down the 45 seconds and retries, without anything
happening.
   There is no response by minicom to typing any of these: AT<return>,
ATZ<return>, AT&V<return>, or ATDT<the number><return>.
* The command line instructions (borrowed from PPP-setup tips at RedHat
website)
        # cd /etc/sysconfig/network-scripts
        # ./if-ppp ifcfg-ppp0 &
yield the following only:
        [1] 2212
* The proper ppp files and directories are all there in /etc/ppp (but
not
in /usr/sbin ... should there be symbolic links in /usr/sbin?)
* When I run "cat /proc/interrupts", it lists (among others):
        14: 12370 + ide0
        15:    39 + ide1
In particular, there is no IRQ labeled "serial" (should there be?)
* /dev/modem is a symbolic link to /dev/cua0.   Using modemtool I tried
changing
this to /dev/cua1 ; this made no difference.  Likewise, changing it to
/dev/cua2 or to /dev/cua3 didn't help either.

I might believe that my scripts are set up incorrectly, etc., but since
I don't
hear any tones, isn't my problem more basic than that?

Much gratitude in advance

David Anick
dja genesis mclean org


-- 
  PLEASE read the Red Hat FAQ, Tips, Errata and the MAILING LIST
ARCHIVES!
http://www.redhat.com/RedHat-FAQ /RedHat-Errata /RedHat-Tips
/mailing-lists
         To unsubscribe: mail redhat-install-list-request redhat com
                     with "unsubscribe" as the Subject.

	Problems should be addressed to <listmaster redhat com>.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]