[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: isapnp



Redhat 5.2 comes with isapnp.  It might already be installed on your
system.  You may wish to reinstall if it isn't (or, just find the RPM's on
the CD).

Anyway,  here is a e-mail that has been posted by Jose Sanchez several
times a day for the past week or so.  It worked for me.  Give it a try.
(Note, I have a SB AWE 64...so things might ba a little different.)

If this doesn't solve your troubles, check the Sound How-To

Dave


----- Old Message begins... ---

Here is a copy of a message I sent to Peter Spalding detailing the
proceedure to get things to run...

You must also specify the -a parameter to playmidi to get it to work...

See the help for playmidi and Xplaymidi

Actually this is ALL documented in the SOUND howto's...

Read them for further information and explanations...
Post your sucess or failures with the above to the list so that others may
benefit...

-JMS
----- Original Message -----
From: Peter J Spalding <pjs iserv net>
To: Jose M. Sanchez <opjose ex-pressnet com>; <redhat-list redhat com>
Sent: Thursday, March 18, 1999 1:01 PM
Subject: RE: SoundBlaster.... Again


> Ok...I tried what you said.
> I recompiled my kernel for Modular Sound.
> However, there is no pnp.conf in my /etc directory.  perhaps your
referring
> to pnpisa.conf?

Yes, isapnp.conf MUST be edited to correspond to the AWE's PNP settings as
assigned by the bios. Normallyt the first set of entries (each FIRST line
you see which looks like the ones below) need to have the comment "#"
removed from the beginning of the line.

(INT 0 (IRQ 5 (MODE +E)))
(DMA 0 (CHANNEL 1))
(DMA 1 (CHANNEL 5))
(IO 0 (BASE 0x0220))
(IO 1 (BASE 0x0330))
(IO 2 (BASE 0x0388))
(ACT Y)

This gets the kernel to intialize the card properly, but does not yet
install the sound modules...
Make sure you only "uncomment" one set of entries which are grouped together
(normally the first ones), ending with the (ACT Y), meaning activate it...

Once done reboot, and run sndconfig, sndconfig will add entries into the
/etc/conf.modules file
Edit the file to have lines which look like this...

alias sound sb
options -k sb io=0x220 irq=5 dma=1 dma16=5
alias midi awe_wave
options -k awe_wave
alias midi01 opl3
options -k opl3 io=0x388
alias sequencer uart401
options -k uart401 io=0x330

The first alias assigns the sound device to the sb driver.
The options line sets the parameters for the sb driver (note if you are not
running a 2.2.x kernel the first options line should look like this....
options -k sb io=0x220 irq=5 dma=1,5) The syntax was changed with the 2.1.x
kernels and above...

The second alias makes the machine believe that the AWE synth is a MIDI
device, so you can fully utilize the on board AWE synth. The next alias also
makes midi device 01 use the OPL chipset on the card.

The last alias permits you to use Linux Midi programs (like Rosegarden) with
an external midi instrument..

If you have a SCSI hard drive you'll need to RECREATE the
/boot/initrd-xxxxx.img file after making the above changes so that the
kernel boot image will already contain the sound modules...

While the above will make the AWE fully functional, when first turned on the
AWE does not have any samples loaded, not even those on board the built in
ROMS!!!

SOOO you'll need to add a line to your /etc/rc.d/rc.local file like this...
#
# Load up the AWE
#
/usr/bin/sfxload /etc/synthgm.sf2

Of course both the sfxload and synthgm.sf2 files must exist in their
respective directories..

Now you can even play midi files via the AWE's built in synth...

Simple huh?

Actually this is ALL documented in the SOUND howto's...

Read them for further information and explanations...
Post your sucess or failures with the above to the list so that others may
benefit...

-JMS
opjose ex-pressnet com




At 08:57 AM 3/24/99 -0500, you wrote:
>Greetings--
>
>I just got RH5.2 and have been trying to set it up on my standalone PC.  
>
>I wasn't able to set up sound (Sound Blaster 16) or access my internal
>modem (Hayes Accura) and was advised to try using "ISAPNP".
>
>I found the isapnp package on Red Hat's FTP site and tried to 
>install it. When I did that, I got these messages: 
>
>"Failed dependencies. libc.so.6 (GLIBC_2.1) is needed by isapnptools-1.18-1."
>"Failed dependencies. libc.so.6 (GLIBC_2.0) is needed by isapnptools-1.18-1." 
>This is greek to me. 
>
>Which specific libraries do I need to install for the installation of
>PNPtools to happen?
>
>I thought I had installed just about everything from the Red Hat 
>installation CD #1.  Is what I need someplace else?
>
>Thanks for any help.
>
>Dean Pierce
>
>
>
>-- 
>  PLEASE read the Red Hat FAQ, Tips, Errata and the MAILING LIST ARCHIVES!
>		http://www.redhat.com http://archive.redhat.com
>         To unsubscribe: mail redhat-install-list-request redhat com with 
>                       "unsubscribe" as the Subject.
>


   -----------
"Today's Computer Science lecture will be conducted entirely through the
medium of interpretive dance." - something I've always wanted to hear but
never will.

E-mail:  "David Royer" <David D Royer-1 tc umn edu>
PGP Public Key available upon request, or from the following web sites:

RSA Key: http://pgp5.ai.mit.edu:11371/pks/lookup?op=index&search=0xB7284FBB
DSS Key: http://pgp5.ai.mit.edu:11371/pks/lookup?op=index&search=0x5BF8F3C8




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]