[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

kppp, xhost, and starting X

I've recently built a new computer and installed Red Hat 6.2 on it.
When I tried to run kppp from my mortal account using the console
application it installed with, I got an error message

     Xlib: connection to ":0.0" refused by server
     Xlib: Client is not authorized to connect to Server
     kppp: cannot connect to X server :0

I didn't have this problem with 6.1, and it looks to me like root can't
open a window on the machine.  When I use

     xhost + localhost

It will work fine.  However, I want set up the account so that it issues
the xhost command every time I start X.  I thought I could put it in the
file ~/.Xclients, and I tried that (with .Xclients executable by
everyone), and it doesn't seem to work.  I logged out and then back in,
and I even rebooted the machine.

On a separate, but related, issue, it won't accept the command xhost +
root@, which I thought should work.  I even tried it on my other machine
which is running 6.1 and it doesn't work there, either, but it does work
on some Solaris machines I have access to at work.  The message I get is
something about the integer not being recognized.  (I'm sorry, but I'm
not on the machine right now to try to reconstruct the message.)

Any and all help would be greatly appreciated.


Will Turner
wjturner math ncsu edu

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]