[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

solved: emtpy extended partition kills install (was Re:RedHat 6.1 installation reboots before writing partitions)

(This message was returned to me.  Sorry it's so delayed)

Thanks for all the information.  I looked at this again last night and
noticed something I hadn't seen before.  In NT's Disk Adminstrator, it
showed my 4 gig NTFS partition, then the free space was actually split
up into 2 boxes, both labeled as "free space".  When I clicked on one of

them, it said it was "free space on extended partition" while the other
one just said "free space".  Anyway, I deleted this extended partition
so that I only had one partition on the drive.  Then I retried the
RedHat install and it worked fine.

So why did this extended partition of free space cause the RedHat
install to just crash and not report any error?  And why didn't this
partition show up in Disk Druid during install?  Disk Druid only
displayed the NTFS partition.  This was with the latest boot image which

fixes the problem of NTFS partitions not being recognized.

I did run into another interesting issue that may apply to someone.
Actually, I should make that a separate post.  Thanks again to everyone
who responded.


Thomas Dodd wrote:

> Stuart Mace wrote:
> >
> > > Ok, I've been spending a little time at the RedHat site.
> > > First, I don't know
> > > where the "8GB limit" came from.
> >
> > neither do I, tho from experience I know it exists.
> It has to do with the way BIOS writers implemented LBA.
> First there was a 2G limit since the BIOS didn't
> implement the spec completely. Later there was an 8G
> limit for the same reason. (I have a IDE card that
> suffers from this). Now The problem is around
> 32G. When ATA (IDE) spec was updated to ATA-2 (EIDE)
> they added LBA translation, drives were in the
> 512M - 1G range. So BIOS writers took a shortcut
> and didn't follow the spec. Now the spec is running
> out of bits for total sectors (LBA modes) and the 32G
> limit is an issue. Ask people with 36G drives :)
> > > reboot and run the Redhat install.  Does anyone know
> > > how to boot far enough into linux to run fdisk before
> > > actually installing Linux?
> On the screen where you select GNOME, KDE, Server, Custom, or
> Upgrade, look in the top-right corner for a check box
> that sars use fdisk. You may need to boot expert mode to get it.
> Then, instead of Disk-Druid, you get fdisk to create the partitions.
> after creating the partitions, writing them, and exiting fdisk,
> you'll see the "assign mount points" page.
> You can reboot from here to verify the partitions
> were written correctly.
>         -Thomas

Do You Yahoo!?
Talk to your friends online with Yahoo! Messenger.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]