[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: Apache doesn't work in 6.2

It is NOT a permission problem just a slight error in httpd.conf.

Open /etc/httpd/conf/httpd.conf.
Find  The line "# Controls who can get stuff from this server."
Edit the next line to be:
<Directory /"/home/httpd/html">
Do the same for .....httpd/icons>
Do the same for .....httpd/cgi-bin>

Yehuda Feinsilber

-----Original Message-----
From: Derek mail redhat com [mailto:Derek mail redhat com]On Behalf Of Derek
Ryan White
Sent: Sunday, May 21, 2000 9:18 PM
To: redhat-install-list redhat com
Subject: Re: Apache doesn't work in 6.2

I get the same Forbidden error and I have even changed ALL the
subdirectories permissions. I did these changes:

[root dereksbox /]# chmod a+r /
[root dereksbox /]# chmod a+x /
[root dereksbox /]# chmod a+r home
[root dereksbox /]# chmod a+x home
[root dereksbox /]# cd home
[root dereksbox home]# chmod a+r httpd
[root dereksbox home]# chmod a+x httpd
[root dereksbox home]# cd httpd
[root dereksbox httpd]# chmod a+r html
[root dereksbox httpd]# chmod a+x html
[root dereksbox httpd]# cd html
[root dereksbox html]# dir
index.html  main.html  poweredby.png
[root dereksbox html]# chmod a+r index.html
[root dereksbox html]# chmod a+x index.html
[root dereksbox html]# chmod a+r main.html
[root dereksbox html]# chmod a+x main.html

I did the a+r so that you could read the directories and the files, then I
did the a+x so that you would be able to access everything ('man chmod' told
me to use the x for the directories).  Even after all that I still get the
Access Forbidden to / direct
ory message.  /home/httpd/html is the root directory as set in httpd.conf.
The httpd user is nobody and it is running on the normal port 80.  What is
wrong with this?  I am using version 1.3 of Apache and RHLinux 6.2 as well.

Point Of Reference for me:
Would the command 'chmod a+r+x'  be the same as typing 'chmod a+r' then
'chmod a+x'?
Also, how do I find the owner of a specific file/folder from the terminal
and allow access to it for specific users, such as nobody, and not just all


Kevin Colby wrote:
> Check the file/directory permissions.  You need to allow access
> for everyone (or at least 'nobody').
>         - Kevin Colby
>           kevinc grainsystems com
> Jonas Fornander wrote:
> >
> > I have installed a plain vanilla server installation of 6.2. However I
> > get Apache to work. When I try to access the default document I get the
> > following error:
> >
> > Forbidden
> > You don't have permission to access / on this server.
> >
> > I tried some suggestions on this list  but could still not get it to

Do You Yahoo!?
Talk to your friends online with Yahoo! Messenger.

To unsubscribe: mail redhat-install-list-request redhat com with
"unsubscribe" as the Subject.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]