[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: NT OS Loader + Linux = how?

lawson_whitney juno com wrote:
> Yes.  Have you not seen my replies to your earlier letters on this, or
> is it just that you can't make sense of them?  :-).  Maybe you are
> frustrated with lilo and the initrd?  OK.  Shall we dispense with them?

Sorry for not answering earlier. I get lots of email these days and my
ISP has some technical problems to speed up its traffic. Well I am not
so frustrated as you think, but I plan to get frustrated soon :-)

> Because the target system is SCSI, and you don't want to use lilo, you
> are going to have to make a custom kernel.

No, who says I don't want to use lilo? I like lilo, but lilo doesn't
like me :-)  Ok, here you have what I've done today:

After I discovered that there is no way to make proper /etc/lilo.conf to
re-boot newly installed Linux, I decided to try the installation onto
the 1st SCSI disk only. Well, there I already had NT installed as well
as NT boot loader within the MBR. So, I did the following:

1) I got my PQ Magic diskette to shrink NT's NTFS partition from cca
2032 MB to cca 620 MB (in order to release some 1.4 GB of free space at
the beginning of disk, where I wanted to install RedHat 6.1 full

2) Before doing that, I tried one more time old Caldera 1.2 and its
fdisk described shrinked NTFS partition as /dev/sda1 (BTW, could anybody
explain why it think it was /dev/sda1 instead of /dev/sda2 because NT
was shrinked/moved away from the beginning of the disk? Seemed
reasonable to me that this partition should become /dev/sda2 so I could
make a /dev/sda1 from the free space preceeding shrinked part?). Beside
that, Caldera's fdisk said about NTFS partition: partition 1 does not
end on cylinder boundary: phys=(258,254,63) should be (258,63,32). That
diagnose I haven't got before.

3) Anyway, I made from the free space a new Linux native partition and
it was reported as /dev/sda2. (swap partitions I already had on
/dev/sdc2 and /sdd2).

4) I made an installation of Caldera 1.2 onto /dev/sda2. So far, so
good. During the process, everything was fine, so I could also edit

5) I asked for lilo to place into /dev/sda and /root=dev/sda2

6) Then I also added an entry for some earlier installed RH 6.1

7) /sbin/lilo reported: Added Caldera *
                        Added Redhat 
  what looked ok?

8) Then I also tried to add an entry for NT from within /dev/sda1
(other=/dev/sda1, label=nt), after what /sbin/lilo reported: warning
device 0x0801 exceeds 1024 cyl limit, device 0x0800 invalid partition
table, 1st entry, 3d address: 1/1/179 (366624), linear address:
19/9/1404 (2875698).

9) I considered that this won't work, so I removed 'nt' entry.
/sbin/lilo reported everything ok again like under 7).

10) But, after re-boot, system again hangs after 'LI'.

11) Of course, nothing was booted, so I had to make DOS fdisk /mbr in
order to recover NT's loader at least :-)

12) After next re-boot I only got: "invalid partition table"  :-(

13) Once again, I used Caldera's fdisk and deleted /dev/sda2.

14) Next re-boot: NT started ok again (God bless :-))

15) I decided to try RedHat's Gnome Workstation installation (that I
never tried before on a server type of hardware). It reported to remove
any Linux installation if it find them on all disks.

16) After the setup was completed, next re-boot with lilo was successful
(finally :-)). Interesting: it reported that /root=/dev/sda6 (why 6 ?)
and there were two choices: linux and linux-up (what is the purpose of
'up' version?)

17) I edited lilo.conf and added 'nt' entry as like under 8) to see what
would happen.

18) Next re-boot: lilo with linux, linux-up and nt entries.

19) If I type 'nt' from within lilo, it goes to NT's standard loader

20) If I type 'linux', it boots Linux. Wow, I've made it :-)

Some additional notes:

- Looks like RH 6.1 is more easily to be installed in a 'workstation'
than 'server' or 'custom' version (in conjunction with NT previously

- It made 3 partitions from the free space I got at the beginning of the
1st disk (cca 20, 1300, 70 MB respective) and removed everything that
looked like Linux from the 2nd, 3rd and 4th disk. So I consider that
20MB is /boot, 1300 is /root and 70MB is swapp. These three and NTFS are
in sum of 4 partitions (all of them located on the 1st scsi disk and
other disks are empty). So I wonder why it reports /root is /dev/sda6.
Any idea?

- It was no need to make additional setup, covered by NT-Linux-howtos,
regarding the use of NT's loader for booting linux, beside NT and
NT-vga. I made it in opposite way: Lilo to boot NT, beside Linux.

- Is there any reasonable explanation, why 'custom' or 'server'
installations of RH 6.1 are difficult (regarding lilo and booting) in
case where there is server dedicated scsi hardware? Is there a way to
add-on or make an upgrade some 'server' options after a workstation has
been installed?

- Btw, I got Linux working in text mode (I asked for Gnome Workstation
when I started the setup). How to start xconfiguration (just: startx
won't work)?

- Is there any possibility for Linux to make some influence to a
partition where NT is placed? I just don't want to have neither NT nor
Linux making troubles to each other. I'd rather to have them working in
a way they are only OS installed in the box. There I have 3 scsi disks
left, some of them should be formatted as FAT - in order to share some
files or so. Would be ok for Linux to use one of the remaining disks in
ext2fs and NT to get one as NTFS and the rest one as FAT for file
exchange? Any comment?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]