[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Bridge Traffic Shaper w/ MRTG Traffic Monitor.

    I have a Pentium III - 450Mhz - 256MB RAM - 2 DE500 Fast Ethernet - Red
Hat Linux 6.2 w/ Kernel 2.2.17 w/ bridge and QoS support. I want to make a
Packet Shaper that Connects my LAN and WAN.
    The bridge and QoS (cbq) are working ok, and I have assigned an IP to
this bridge, because I want to connect it from a telnet client software to
configure it.


    I want to get information about current input and output traffic through
my bridge by IP or cbq class to report with MRTG.
    I know I can use the command "cbq.init stats", and it will show me the
current traffic by class, but it is not showing on my box. It is always
showing  0 bytes, but the cbq shaper is working properly.
    I think it is showing (0 bytes) because I'm using this box as a bridge
shaper, and not as a router shaper. In this bridge, I set my eth0
IP:, and eth1, and brg0
After that I tried to set the eth0, and not assign an IP to the
brg0, but without success.
    Is there anything wrong (I have never worked with bridges...) ? The
bridge support was compiled in my kernel, and it is not a module.
    Another way to get traffic from a box, is inserting rules with ipchains
and getting results typing "ipchains -L -x -v".
    If I type "ipchains -L -x -v", I can see my input and output chains,
there is traffic through my bridge, but if I put a rule like: "ipchains -I
input -s my_lan_ip", and then I type "ipchains -L -v -x", it  shows me n
bytes (not zeroes) in my input chain, but in that rule (I set with a lan
ip), it shows 0 bytes. I tried to reverse the rules, without success.
    Can anyone help me ?

    Thank You For Reading My Mail... It's too large!!!

   Ricardo Alexandre Trombetta - ricardot netcomp com br

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]