[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: RPMs - Frustration sets in.

Ah, yes..... 

[root Linus /root]# rpm --rebuilddb
failed to open //var/lib/rpm/packages.rpm

[root Linus /root]#

First thing I tried when I started having the problems, and the symptom I
trying to describe to folks.
However, based on the first truly helpful comments on it, I was able to 
locate the following entry in /usr/lib/rpm/macros:

# ---- filesystem macros.
%_usr                   /usr
%_usrsrc                %{_usr}/src
%_var                   /var

I edited the last line (temporarily!) to read

%_var				var

And that DID fix the problem with //var, though heaven knows what other
problems will now crop up because something else is wrong... 

Unfortunately, now I'm getting a new error (which is popping up
both ways, with /var and //var)

error creating directory /var/lib/rpmrebuilddb.6398: No space left on device

Ok, now THAT's patently ridiculous.

[root Linus /root]# df
Filesystem           1k-blocks      Used Available Use% Mounted on
/dev/hda1              2289010   1070441   1100232  49% /
[root Linus /root]# 

I have a single partition on this machine (I've gotten more sophisticated
since the original build, but this was an upgrade of a 5.2 machine).  I
can do a

[root Linus /root]# touch /var/lib/rpmrebuilddb.6398
[root Linus /root]# ls /var/lib/rpmrebuilddb.6398
[root Linus /root]#

so I know that there is nothing wrong in the directory, either.

I >REALLY< don't want to have to slick this system... I won't lose much
except time, but it's a pride thing... anything goes wrong in Windows,
the only alternative is to reinstall fresh.  I've told a LOT of folks that's
not true in Unix... and pushed them towards Linux.  Now I'm finding myself
stymied on this, and on the verge of slicking it and starting over...
Like I said in the title to the original message, "Frustration sets in".

Bill Ward

-----Original Message-----
From: Matt Housh [mailto:jaeger morpheus net]
Sent: Wednesday, March 01, 2000 1:24 PM
To: redhat-list redhat com
Cc: recipient.list.not.shown; @nswcphdn.navy.mil
Subject: Re: RPMs - Frustration sets in.

> > Ok, so I have to do a Microsoft and reinstall RH6.1 since the RPM
> > database has become corrupted and no one seems to know how to fix
> > it.... I can deal with that.  Now I'm having problems with my other
> > 6.1 system and the RPMs, but this is a side effect of the developers
> > getting careless, it appears.

	Tried 'rpm --rebuilddb' ?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]