[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Network Installs on a low memory 486.... how do I do it?



Ok, I'm starting to get a bit down on this... last week, someone asked if
you can
install RH6.2 on a 486, and I confidently piped up "Sure!"  Now, I'm not so
sure
that if can be done as easily as I thought.

Ok, here's the deal... I bought a 486 cheap a couple of weeks back to use as
a
firewall/printserver (and maybe a SAMBA server, too).  It's not critical
that I
have it running YET... Cable modems are coming in the spring (when this
machine
is needed), not this fall.  But I'd still like to have it running.

The machine was a 486 DX2-50 with built in 1 MB VLB video, a 3COM Ether
Express III, 16 MB of RAM, a mouse, keyboard, SVGA monitor, floppy, and
a Quantum 304 MB IDE HD.  I had a few spare parts that I'm not using, 
so I slapped in a better Video (a 2 MB VLB #9 GXE 364 Video) and a 
WD 1.6 GB EIDE HD.  I also attempted to slip in 32 MB of RAM that I 
had, but was stymied when I found that the machine was a true-blue IBM
ValuePoint, with proprietary memory constraints.... this is one of 
my two big problems, I think.

You'll notice that I have no CDROM for this computer; the intention was to
do a network install using the CDROM mounted NFS from my K6/2-500.   I've
successfully done those kinds of installs before, but only when I've
had time to troubleshoot the NFS mount... I created the bootnet floppy,
stuck it in the machine, and powered up (well, I'd previously figured
out the config.. I'm shortening the tale here).  The install went perfectly
through the NFS mount, which didn't work... oh well.  I'll figure that
out later, when I have two machines to work with.  I mounted the CD
therefore in the FTP area, turned on anonymous FTP, and retried an FTP
install... much better!  The second stage loaded, I formatted the two
HDs (with hda1 being ~50MB as /boot, hda2 being / with the rest of the
drive, hdb1 being 128 MB as swap, and hdb2 being /tmp for the rest of the
drive... wasn't big enough for /var, IMO)  No errors were detected in the
drives, the NIC works perfectly, I'm getting good stuff.  I chose a
Custom install, selected what I wanted, and kicked back for a 3 hour
or so (the machine >is< slow) install.... and waited.  And waited.
And waited.  After thrashing for about 3 hours without getting ANY of
the RPMs installed, I tried to figure out what was wrong.  Does anyone 
know the minimum memory size practical for a network install?  Is 
part of my problem that I put /tmp and swap on the slow, small Quantum?
Is there any way to tweak something to get a decent (even overnight!)
install going?

I'm loathe to do what I think is going to be the suggestion, but I'll
do it as a last resort; pull the drives, stick them in my machine, and
do the install there.  I'd rather not have to do that, as it's such
a huge difference in architecture, plus I don't want to have my 
machine down while doing this.

Any clues to help, folks?  I've even tried RH5.2, RH6.0 and Mandrake 7.0.
Of those, RH5.2 Seg faults during initial install, Mandrake and 6.0 hang,
though I've yet to figure out WHY.  6.2 seems so close.... and yet so
far, when the machine just thrashes.

Bill Ward





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]