[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Upgrading RPM ??



First, thanks all for the replies.

So, just to make sure, all I need is the package
rpm-3.0.5-9.6x.i386.rpm, and then run "rpm --rebuilddb" (just to be save)? I don't need anything else, right?


Thanks again in for any replies

Reuben D. B



At 01:04 PM 6/12/01 -0400, you wrote:
On Tuesday 12 June 2001 12:07 pm, you wrote:
>
> The runnung of "rpm --rebuilddb" is recmmended for upgrading from 3.0.x
> to 4.0.2, because of the format changes between rpm version 3 and rpm
> version 4.  It is not realy critical for upgrading to a newer version 3.
> (But it will not hurt.) Also, you are better off with 3.0.5 then 3.0.6.
> 3.0.6 had some problems, and was never in the official updates tree as
> far as I can tell.  rpm-3.0.5-9.6x.i386.rpm is the latest version 3 rpm
> I found at updates.redhat.com.
>
Ok. I was going from memory. :-) The thing is I grabbed 3.0.6 myself and used
it. The ONLY thing I had to do was use "no-deps" when upgrading it because a
small bug in the specfile. :-) In any case, you're correct. Also, though, re:
rebuilddb, haven't there been a number of cases where the db got corrupted
even upgrading to 3.0.5/6? It's still a good idea to rebuilddb when upgrading
something that major. :-)
        John



_______________________________________________
Redhat-list mailing list
Redhat-list redhat com
https://listman.redhat.com/mailman/listinfo/redhat-list





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]