[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Latest RPM woes



K Old wrote:

Rob,

Tried that and still no success.

[root ns local]# rpm -i glibc-common-2.2-12.i386.rpm glibc-2.2-12.i386.rpm
error: failed dependencies:
       glibc < 2.2-12 conflicts with glibc-common-2.2-12
       glibc > 2.1.3 conflicts with db3-3.1.17-4.6x
       glibc >= 2.1.92 conflicts with rpm-4.0.2-6x


Yup, this will happen, that's what you need the -U flag for.

Now I notice that you have some conflicts which are not directly related to glibc, and this is why I warned against trying this on a hot system. So much depends on your C libraries that you can quickly find yourself in dependency hell. Package A-2.0 needs B-2.0 needs C-2.0... but C-2.0 needs A-2.1. Oops, start over.

Usually when I find that I've outgrown my libc, it's time to look at the next version of my OS distribution.


-- ~~~Michael Jinks, IB // Technical Entity // Saecos Corporation~~~~





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]