[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

rpm upgrade problems



Hi everyone,
Today, with a few minutes on my hands, I decided to upgrade rpm on my redhat 6.2 system from 3.0.4 to the latest 4.0.2. So, after downloading the files, I tried to install them. I ran into the following problem with the rpm-python file:


[root ja: /usr/local/download]# rpm -i rpm-python-4.0.2-6x.i386.rpm
file /usr/lib/python1.5/site-packages/rpmmodule.so from install of
   rpm-python-4.0.2-6x conflicts with file from package rpm-python-3.0.4-0.48

I thought that removing the old rpm-python would fix things, but it doesn't appear to be so.

[root ja: /usr/local/download]# rpm -e rpm-python-3.0.4-0.48
error: removing these packages would break dependencies:
        rpm-python is needed by anaconda-6.2.2-1

Then I used the --force option to install the rpm-python and now rpm tells me that none of the rpm packages are installed!

(Yes, I downloaded the db3 packages and updated the databases and I downloaded the popt package) The problem shows up to me in the kpackage program in kde 1.1.2. Anyone offer any thoughts on this mess?

Thanks,

Mark





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]