[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Error 0X01



On Thu, 3 May 2001, Massimo Alonzo wrote:

> Hi,
>
> I moved my second hard disk from secondary master to secondary slave
> hoping to make my cdburner work (without success); the trouble is that I
> installed RH7 for tests on that disk (as /dev/hdd2) and the system doesn't
> like it.
>
> In detail:
>
> - This partition worked really well when the disk was connected as sec
>   master
>
> - Lilo into my "work installation: /dev/hda4":
>
> I added these 2 lines to boot /dev/hdd2:
>
> boot=/dev/hda       #MBR
> ......
> other=/dev/hdd2
>         label=rh70_test
>
>
> but when I launch "lilo -v" I get:
>
> ...........
> Boot other: /dev/hdd2, on /dev/hdd, loader /boot/chain.b
> Warning: BIOS drive 0x82 may not be accessible
> Added rh70_test
> ...........
>
> - Lilo into my "tests installation: /dev/hdd2":
>
> boot=/dev/hdd2      #First sector of the partition
> map=/boot/map
> install=/boot/boot.b
> prompt
> timeout=0
> message=/boot/message
> default=linux
>
> image=/boot/vmlinuz-2.2.16-22
>         label=linux
>         read-only
>         root=/dev/hdd2
>
> - When I choose rh70_test at boot time I get:
>
> ERROR 0X01
>
> - Bios recognize this disk at startup
> - both /dev/hdd1 and /dev/hdd3 (vfat)  works
>
>
> My questions are:
>
> 1) Is it possible to install linux on a sec slave disk?
>
Yes
>
> 2) What does "Warning: BIOS drive 0x82 may not be accessible" means? My hd
> works .... I tried it.  This message doesn't appear if I connect this disk
> as sec master, or elsewhere (but sec slave :p).
>
Depending on your BIOS, you may or may not be able to access devices on
the second IDE controller using BIOS calls.  It is mainly a problem with
older machines.  If your BIOS has settings for four drives, chances are
you will not have any problems.
>
> 3) What does "ERROR 0X01" means?
>
>From the LILO README file:

0x01   "Illegal command". This shouldn't happen, but if it does, it may
  indicate an attempt to access a disk which is not supported by the
  BIOS. See also "Warning: BIOS drive 0x<number> may not be accessible"
  in section "Warnings".

What I think may have happened is that you ran lilo while the drive was
still connected up as the slave drive on the master controller, and now
that you have moved the drive, lilo is still trying to load from the old
drive location.  (The second copy of lilo - the one on what is now
/dev/hdd.)  This would make sence because you would have to had booted
the second copy of Linux and run lilo after moving the drive, or you
have to know how to run lilo on the first copy and tell it to update the
second copy.  (I will explain how to do this at the end of the message.)

>
> thank you
>
> Massimo
>
>
What you will probably have to do to fix this is something like this:

log in as root.		You have to be root to do this.
mkdir /mnt/root		A place to mount the second root file system.
mount /dev/hdd2 /mnt/root
			Mount the second root file system.  If /boot on
			the second hard drive is a seperate partition,
			you will have to mount it on /mnt/root/boot.
lilo -r /mnt/root	Update the second copy of lilo.

As long as the only complaint lilo gives is the "Warning: BIOS drive
0x82 may not be accessible", you should be all set.

Where you are running into the problem is that you are using two copies
of lilo, and running lilo when you boot your normal copy of Linux does
not update the second copy.  And running lilo on the second Linux
install before moving the disk saves the wrong location information
about how to load the rest of the boot loader.  Lilo saves this
information as drive/cylinder/head/sector, and when you moved the drive
to the secondary controller, the drive information changed.

Mikkel
-- 

    Do not meddle in the affairs of dragons,
 for you are crunchy and taste good with ketchup.





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]