[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Can't update Python



I have a Red Hat 7.0 that I want to upgrade Python on.

[root kramer rpm]# rpm -Uvh python2-*
error: failed dependencies:
        libcrypto.so.0.9.6   is needed by python2-2.1-5
        libssl.so.0.9.6   is needed by python2-2.1-5

[root kramer rpm]# locate libcrypto
/usr/lib/libcrypto.a
/usr/lib/libcrypto.so
/usr/lib/libcrypto.so.0
/usr/lib/libcrypto.so.0.9.6
/usr/lib/libcrypto.so.1
/usr/lib/libcrypto.so.0.9.5a
/usr/local/ssl/lib/libcrypto.a

[root kramer rpm]# locate libssl.so
/usr/lib/libssl.so.0
/usr/lib/libssl.so
/usr/lib/libssl.so.1
/usr/lib/libssl.so.0.9.6
/usr/lib/libssl.so.0.9.5a

Should I just force the update, or is there a way to tell it where to find 
the dependencies?

----------------------------------------------------------------------------
DDDD   David Kramer         david thekramers net       http://thekramers.net
DK KD  
DKK D  "It's noble to be good. It's nobler to teach
DK KD  others to be good, and less trouble."
DDDD                                                              Mark Twain





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]