[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

rpc.mountd: getfh failed

Hey all,

i've got 2 redhat machines. I'm trying to mount on one machine and having one hell of a problem.

mount machine:/ /machine/
mount machine:/disk/export /machine/disk/export

the above 2 mount statements will work.

mount machine:/disk /machine/disk

that mount statement does not work, regardless of what i put in the exports file on machine. The error message in the log file on machine is:

rpc.mountd: authenticated mount request from for /disk (/disk)
rpc.mountd: getfh failed: Operation not permitted

When i run exportfs -a on machine, i get:
machine2:/disk: Invalid argument

I dont even have anything in the exports file anymore allowing machine2 to mount machine:/disk and it still gives me that message when i do exportfs

Can ANYONE give me some suggestions as to how to clear this up? Someone who knows a hell of a lot more about linux then i do thinks it has something to do with something be stuck inside the kernel. I'm not using his exact words. He recompiled and installed a different version of the kernel but that hasnt helped.

I've tried rebooting. I've tried using the machine name, the machine name.domain, and the IP address in the export file. I've rebooted the machine. restarted nfs. Nothing seems to work.

I dont understand why i can mount / and /disk/export, but not /disk

any suggestions?

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]