[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: Problems with Perl in RH 9.0



I chased the same problems for quite some time. Finally found some decent notes on the Net about it. In addition to the changes to /etc/sysconfig/i18n, I also edited .bashrc. After rebooting, everything went well.

--
Eric Robinson


	-----Original Message-----
	From:	Jason Williams [SMTP:jwilliams courtesymortgage com]
	Sent:	Tuesday, July 29, 2003 9:21 AM
	To:	redhat-list redhat com
	Subject:	Problems with Perl in RH 9.0

	Morning everyone.
	I was installing some perl modules today via perl -MCPAN when I ran into a 
	problem.
	I was getting all of these errors and such that were failing and the 
	modules were not being installed.

	After doing some research, I found out that there is a nice bug in the perl 
	shipped with 9.0.
	The fix was to change the following /etc/sysconfig/i18n
	change the line LANG=
	to
	LANG="en_US"

	Remove anything else after it, specifically, .UTF.

	After I did that, things started to work. However, I am still having 
	problems with one package:

	Compress::Zlib

	Here is the error I get when I try and install it:

	make: *** [Zlib.o] Error 1
	   /usr/bin/make  -- NOT OK
	Running make test
	   Can't test without successful make
	Running make install
	   make had returned bad status, install seems impossible

	And this is the last package I need to install and I cant figure it out.
	Anyone have any ideas on how I can fix this?

	Thanks.

	Jason


	-- 
	redhat-list mailing list
	unsubscribe mailto:redhat-list-request redhat com?subject=unsubscribe
	https://www.redhat.com/mailman/listinfo/redhat-list




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]