[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Trouble with GRUB and multiple HD's



On February 7, 2004 06:37 pm, Harry Hoffman wrote:
> Hi Pete,
>
> The drive HAS to be bootable "as it is right now". Otherwise I would never
> know that GRUB was failing at Stage 1.5. The odd bit is that the system
> boots via a boot floppy (or boot cd) from using mkbootdisk. But perhaps
> this isn't so odd as GRUB is eliminated when booting in this fashion. I
> just don't know.
>
> Cheers,
> Harry
>


Harry,
I misunderstood, I thought you had a grub mbr on a floppy (have you tried 
that? i never have) and that worked to launch grub, then the os.

When it fails at stage 1.5, that is between the mbr & the kernel, I beleive 
that is when it reads grub.conf. 
So when it fails,  would that mean it it fails starting or ending 1.5. Could 
that mean it can't access grub.conf?

I just noticed that your earlier post (first?) shows:
kernel /vmlinuz-2.4.20-28.9 ro root=/dev/md0 hdc=ide-scsi vga=791
I don't know if it could matter but vga=791 is invalid, you probably want 
vga=792 

When you boot with the floppy or cdrom, do you get a raid system?
If not, then you may still need to compile a kernel with raid support. If it 
failed at that point it would probably display a kernel panic not just a hang 
at stage 1.5.

just some thoughts.
-- 
Pete Nesbitt, rhce




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]