[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: redhat-list Digest, Vol 55, Issue 24



Hi Mark , 
Thanks for the reply. I tried following 
Boot in Linux rescue mode. 
Skip when asked to mount filesystem. 
Fdisk -l 
This gives me /dev/sda1 as boot 
and /dev/sda2 as linux LVM
Mkdir /mnt
Mount /dev/sda2 -o rw /mnt

Error:Mounting /dev/sda2 on /mnt failed, no such file or directory 

Any thoughts???


Manjiri 







------------------------------------------------------------------------
--------

From: mark <m roth2006 rcn com> 
To: General Red Hat Linux discussion list <redhat-list redhat com> 
Subject: Re: Can not find partitions in linux rescue after missing fstab

Date: Thu, 25 Sep 2008 13:53:11 -0500 

------------------------------------------------------------------------
--------

Hey, there,

Patil, Manjiri S wrote:
> 
> I was playing around with my test machine to get details of linux boot
> process . I renamed my fstab file  from /etc/fstab to /etc/fstab.old .
> Now if I boot machine to linux rescue mode to recover I get error
saying
> there are no partition s to mount.  If I try to mount it manually by
> giving  
> 
> mount  /dev/sda2   /mnt 
> 
> I get error saying no such file and directory. I can't see root
> filesystem mounted. 
> 
> I also tried 
> 
> mount -o remount,rw   /
> 
> But didnn't help.  
> 
> I tried booting into single mode but I can not rename file as its
> mounted as read only. 

When you boot off the rescue disk, it creates a virtual root filesystem,
and
it's running completely from memory. So what you need to do is this: if
there/s
no /mnt, make one. Then mount /dev/sda2 ->read/write - make *sure* it's
that,
because I think the default is ro. Then you can rename fstab, and you
should be
good to go.

	mark



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]