Xen command "xm save" does not finish

Lord of Gore lordofgore at logsoftgrup.ro
Fri Oct 23 12:10:57 EDT 2009


where are you saving the snapshot? do you have enough space? are you
sure it doesn't finish maybe it is still working?
do a 

watch 'ls -l <path_to_snapshot>' 

and see if the dump has stoped. If it stopped we'll go from there :)

Bogdan
http://www.logsoftgrup.ro

On Fri, 2009-10-23 at 12:57 +0200, frank wrote:

> Hi,
> we are running a Red Hat 5.4 Xen cluster and want to try live migration. 
> Our first step has been to try "xm save" on a running domain. But "xm 
> save" does not finish (we don't get the prompt again ). The domain is 
> called xp1 and if we run a "xm list" in another windows, domain name has 
> changed to "migrating-xp1" (?) The only solution of recover it again is 
> to stop "xm save" command with a "control-c" and destroy the 
> "migrating-xp1" domain.
> 
> In xend.log this messages appear:
> 
> [2009-10-23 12:50:11 xend 27918] DEBUG (XendCheckpoint:89) [xc_save]: 
> /usr/lib/xen/bin/xc_save 23 15 0 0 4
> [2009-10-23 12:50:11 xend 27918] DEBUG (XendCheckpoint:324) suspend
> [2009-10-23 12:50:11 xend 27918] DEBUG (XendCheckpoint:92) In 
> saveInputHandler suspend
> [2009-10-23 12:50:11 xend 27918] DEBUG (XendCheckpoint:94) Suspending 15 ...
> [2009-10-23 12:50:11 xend.XendDomainInfo 27918] DEBUG 
> (XendDomainInfo:1249) XendDomainInfo.handleShutdownWatch
> 
> Which can be the problem?
> Thanks in advance.
> 
> Frank
> UPC - Barcelona
> 
> 
> 
> -- 
> Aquest missatge ha estat analitzat per MailScanner
> a la cerca de virus i d'altres continguts perillosos,
> i es considera que està net.
> For all your IT requirements visit: http://www.transtec.co.uk
> 



More information about the redhat-list mailing list