[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Help Needed: My RHEL5 box suddenly stopped accepting e-mails



Hi Richard,


On Sat, May 7, 2011 at 3:38 AM, lists-redhat <
replies-lists-b3z1-redhat listmail innovate net> wrote:

> in your .cf, what do you have as an active (not commented out)
> option the under:
>
>  # SMTP daemon options
>
> tag?
>
> is it:
>
>  O DaemonPortOptions=Port=smtp,Addr=127.0.0.1, Name=MTA
>
> or something more along the lines of one of the following:
>
>  O DaemonPortOptions=Name=IPv4, Family=inet
>
>  O DaemonPortOptions=Name=MTA
>

I have the choice immediately above in my sendmail.cf:
DaemonPortOptions=Name=MTA


>
> The first, with the 127.0.0.1, is the default for RHEL and will only
> accept localhost mail. The other two are forms will allow it to
> accept mail from off localhost.
>
> If that looks ok, try telnetting to port 25 on this machine from
> off-host - e.g., from the exchange server. Do you get a "connection
> refused" response or a "hang". If "connection refused", then it's
> most likely the sendmail daemon doing the blocking. If you get a
> "hang", then it's likely a firewall of some nature, e.g., iptables.
>

I get "connection lost" or "Connection timed out"; depending on the computer
I use to run telnet.
The "connection lost" is what my Windows XP box returned; and the
"Connection timed out" is what
another Linux box returned.


> Have you looked at your machine's logs (maillog, messages, secure
> being the most obvious) they may give some hints.
>

Yes.  I have looked at those, as has the company's IT dept.  But there were
no messages that
would help with this issue.


>
> Have you restarted sendmail?
>

Yes.  I've also rebooted a coupled of times; nothing seems to help.

It's just so weird that with no obvious changes made (except for the updates
applied and then
downgraded that I mentioned in my initial message) that my box would just
all of the sudden
stop accepting email.

Thanks very much for the reply.  I greatly appreciate the ideas.

Regards,

-- 
Mun



>
>       - Richard
>
>
>
> ------------ Original Message ------------
> > Date: Friday, May 06, 2011 04:48:34 PM -0700
> > From: Mun Johl emulex com
> > Subject: RE: Help Needed: My RHEL5 box suddenly stopped accepting
> e-mails
> >
> > Hi Richard,
> >
> > Thanks for your reply.
> >
> > I had saved off /etc/mail when we first got email working properly
> > on my system (a couple of years ago) and I compared the current
> > sendmail.cf to the "known good" copy.  The only difference I see
> > is that IT has uncommented the following line:
> >
> > O Timeout.ident=0
> >
> > With respect to sendmail.mc, the version currently used by the
> > system had the following lines commented out:
> >
> > MASQUERADE_AS(`mydomain.com')dnl
> > FEATURE(masquerade_envelope)dnl
> > MASQUERADE_DOMAIN(localhost)dnl
> > MASQUERADE_DOMAIN(localhost.localdomain)dnl
> >
> > I'm not too experienced with sendmail, but it doesn't appear to me
> > as if the changes above would result in the problem I am having;
> > does it?
> >
> > Regards,
>
> ------------ End Original Message ------------
>
>
>

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]