[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Live upgrade from RHEL 5.7 to RHEL 6.2



On Fri, Mar 30, 2012 at 1:31 PM, <m roth 5-cent us> wrote:

> Christina Salls wrote:
> > On Fri, Mar 30, 2012 at 9:53 AM, <m roth 5-cent us> wrote:
> >> Christina Salls wrote:
> >> > On Fri, Mar 30, 2012 at 8:14 AM, mark <m roth 5-cent us> wrote:
> >> >> On 03/30/12 07:36, Christina Salls wrote:
> >> >>> On Thu, Mar 29, 2012 at 7:09 PM, Grzegorz
> >> >>> Witkowski<geslinux gmail com>**
> >> >>> wrote:
> >> >>>>  On Thu, Mar 29, 2012 at 8:01 PM, Christina Salls
> >> >>>>> <christina salls noaa gov>**wrote:
> >> >>>>>>
> >> >>>>>>  I have just completed a live upgrade from RHEL 5.7 to RHEL 6.2.
> >> >>>>>> My system seemed to boot up fine, watching the console output.  I
> >> >>>>>> cannot, however, access the console through the mouse or
> >> >>>>>> keyboard. I can ssh in and looking at /var/log/messages, it
> seems as though it
> >> >>>>>> recognized the keyboard and mouse:
> >> <snip>
> >> >>> recommended the upgrade in place.  I was just looking for some
> >> >>> troubleshooting advice on the mouse/keyboard issue.
> >> <snip>
> >> > Oh, one more question: are you running at runlevel 3 or 5?
> >> >> <snip>
> >>
> >> > I am running at 5.
> >>
> >> AH! The light begins to dawn, possibly. Have you looked at
> >> /etc/X11/xorg.conf?
> >>
> >       I moved it out of the way in run level 3 and tried to startx
> >
> > [root panther X11]# startx
> > xauth:  creating new authority file /root/.serverauth.11796
> <snip>
> > (EE) MGA(0): [drm] Direct rendering only supported with
> > G200/G400/G450/G550.
>
> Um?
>
> > expected keysym, got XF86TouchpadOn: line 120 of inet
> > expected keysym, got XF86TouchpadOff: line 121 of inet
> > (EE) Failed to load /usr/lib64/xorg/modules/input/evdev_drv.so:
> > /usr/lib64/xorg/modules/input/evdev_drv.so: undefined symbol:
> > xf86GetMotionEvents
> > (EE) LoadModule: Module evdev does not have a evdevModuleData data
> object.
> > (EE) Failed to load module "evdev" (invalid module, 0)
> > (EE) No input driver matching `evdev'
> > (EE) config/hal: NewInputDeviceRequest failed (15)
> > (EE) Failed to load /usr/lib64/xorg/modules/input/evdev_drv.so:
> > /usr/lib64/xorg/modules/input/evdev_drv.so: undefined symbol:
> <snip>
> EE is *not* good.
>
> > (EE) config/hal: NewInputDeviceRequest failed (15)
> > gnome-session[11899]: WARNING: Could not make bus activated clients aware
> > of DISPLAY=:0.0 environment variable: An SELinux policy prevents this
> > sender from sending this message to this recipient (rejected message had
> > sender "(unset)" interface "org.freedesktop.DBus" member "Hello" error
> > name
> > "(unset)" destination "org.freedesktop.DBus")
> > gnome-session[11899]: WARNING: Could not make bus activated clients aware
> > of GNOME_DESKTOP_SESSION_ID=this-is-deprecated environment variable: An
> > SELinux policy prevents this sender from sending this message to this
> > recipient (rejected message had sender "(unset)" interface
> > "org.freedesktop.DBus" member "Hello" error name "(unset)" destination
> > "org.freedesktop.DBus")
> > gnome-session[11899]: WARNING: Could not make bus activated clients aware
> > of
> <snip>
> > Now my session is hung.
>
> Of *course* it is, you're being "protected" by selinux!
>
> Question 0: do you require selinux enforcing?
>
> Test to see if you can boot by bringing up the box in permissive or
> disabled mode.
>
> That being said, I'm not sure that selinux is the only problem - those
> missing symbols seem to indicate that something was either touched, or
> installed, from another repo that conflicts with the repo that you
> installed the o/s from.
>
> I think that is a good clue.  The original RHEL 5.7 installation also
included SGI Foundation.  I have not upgraded that with the "get one thing
working at a time" philosophy.  I am not so sure that was the right
approach.  I have a spare disk to experiment with, so I actually have my
original safely on a shelf.  I am considering installing 6.2 from scratch,
and trying to get the cluster manager software configured from scratch as
well.  Ambitious, but I think upgrade in place has it's own set of problems
that might cascade one into the next.  I will disable SElinux and see what
I find out, but I am sure you are right.  That is not my only problem.
 Thanks for looking at this.  I appreciate your time.  I will probably give
this a bit more time and see what trouble I can get into with a fresh
install.

Christina



>      mark
>
> --
> redhat-list mailing list
> unsubscribe mailto:redhat-list-request redhat com?subject=unsubscribe
> https://www.redhat.com/mailman/listinfo/redhat-list
>



-- 
Christina A. Salls
GLERL Computer Group
help glerl noaa gov
Help Desk x2127
Christina Salls noaa gov
Voice Mail 734-741-2446

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]