[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [rhelv5-list] EXT3-fs: unrecognized mount option "defaultsi" or missing value, changed back to "defaults" but still can't boot!!



Jan Iven wrote:
On 04/12/07 00:41, t35t0r wrote:


To try to fix it, I booted up knoppix, vgscan, vgchange -a y, mount
/dev/myvg/rootvol /mnt/rootvol, and then edited the
/mnt/rootvol/etc/fstab file deleting the extra 'i'. I rebooted but I
still get the error above. I even copied the /etc/fstab from another
working RHEL5 system and I still get the same error as above. Also
cleaned out /etc/mtab but it didn't help. What's going on? Where is it
getting the "defaultsi" option from? It definitely isn't in /etc/fstab
or i'm hallucinating and vim isn't working properly because /i didn't
return anything in the file! help!

the /etc/fstab mount options get copied into the initrd, run "mkinitrd" in the rescue boot (with correct options for your kernel etc) and you should be fine.

(This had bitten me in the past for things such as "nodiratime" - which plain "mount" would grok, but not the reduced-feature-set mount inside the initrd..)

Best to use the RHEL rescue disk (I assume there's one, the FC6 rescue will do if not) and repair from there.

For starters, it knows about selinux, lvm etc. I'm a great fan of Knoppix, it's my favourite rescue disk for most Linux, and for Windows.



--

Cheers
John

-- spambait
1aaaaaaa coco merseine nu  Z1aaaaaaa coco merseine nu
-- Advice
http://webfoot.com/advice/email.top.php
http://www.catb.org/~esr/faqs/smart-questions.html
http://support.microsoft.com/kb/555375

You cannot reply off-list:-)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]