[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [rhelv5-list] Re: Berkeley DB version mismatch



Chris Adams wrote:
Once upon a time, Brian Hechinger <brian hechinger jefferson edu> said:
Is there any particular reason that on RHEL5 the OpenLDAP server rpm ships with its own db library which is 4.4 and yet the Berkeley package that is in the yum repo is 4.3?

OpenLDAP (and rpm, mysql, and maybe some other "heavy" users of db4)
internalizes db4 for compatibility and stability.  IIRC this is actually
the recommended way of using db4 in a project (not always a good thing
when it comes to updates and such though).
I can't say I agree at all with that recommendation.
Why is db4.4 not in the repo? This is rather irritating as I can't use the db utils on my ldap databases.

The correct utils are included with OpenLDAP.  Try slapd_db_checkpoint,
slapd_db_archive, etc.
And this is why.

I'll say no more. ;)

-brian


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]