[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: [rhelv5-list] vncserver

Hey Bill,

	a couple of things:

1) check for the Xvnc process running (that's the server) - it appears
to be: 

ps -ef | grep Xvnc

2) you can also use lsof to check the open ports:

lsof -P -i tcp:5813 -i tcp:5913

3) Typically, the first time you run vncserver, you will be prompted for
a password - this is what is needed to connect with the vncviewer. You
can change it with vncpasswd.

4) when you run vncviewer from XP, you need to enter the host and
desktop (i.e., ":13" in your example), and the provide the password from
#3 when prompted. The port number is important.

In your telnet examples, you are connecting from and to the same box -
can you telnet from your XP system to the linux system?


-----Original Message-----
From: rhelv5-list-bounces redhat com
[mailto:rhelv5-list-bounces redhat com] On Behalf Of Bill Watson
Sent: Thursday, December 06, 2007 9:26 AM
To: 'Red Hat Enterprise Linux 5 (Tikanga) discussion mailing-list'
Subject: [rhelv5-list] vncserver

Preamble: I have never installed vncserver on RedHat before! Didn't
sleep in
a Holiday Inn Express either.

When I use my XP vnc viewer to attempt access, it says 'unable to
connect to
host: Connection refused(10061).

I tried to launch vnc server on 5.0 and now on 5.1. To launch, I simply
typed vncserver at a root # sign. I also tried vncserver :13. I have
configured both 5.0 and 5.1 (two different systems with identical
installed this week) to turn off the firewall and to not use selinux per
installation dialog. On the first instance, the vncserver dialog asked
for a password. Apparently it liked it, since subsequent sessions did

I ran nmap -v -sV (ip)   **really cool command!**  and didn't see the
ports, but then I tried to telnet into ports 5913 and 5813 and got the
dialog that follows my sig line. This, coupled with the .log file (after
telnet commands below) are trying to hint that I did it right.
Unfortunately, since it doesn't work, I did something wrong.

The .log file shows it's unhappiness with my hand telnet sessions, but
not increase in size by even one byte when I appempt to connect from a
vnc viewer (free 4.1.1) from my XP system. My XP can connect to other XP
systems that are running server.

In searching the web, I see many instances of a firewall being in the
On the 5.1 system, it has no firewall set up and is on my local lan. On
5.0, it is about 80 miles away on a wide open T-1 line. I *think* I have
that possibility covered.

Please help me find the intuitively obvious thing that I missed, and how
do it!

Thanks in advance!
Bill Watson
bill magicdigits com

[root nedrhealy .vnc]# telnet 5913
Connected to nedrhealy.com (
Escape character is '^]'.
RFB 003.008

Connection closed by foreign host.
[root nedrhealy .vnc]# telnet 5813
Connected to nedrhealy.com (
Escape character is '^]'.
HTTP/1.1 400 Bad Request
Server: RealVNC/4.0
Date: Thu, 06 Dec 2007 16:41:26 GMT
Last-Modified: Thu, 06 Dec 2007 16:41:26 GMT
Connection: close
Content-Type: text/html

<TITLE>400 Bad Request</TITLE>
Bad Request
Connection closed by foreign host.
[root nedrhealy .vnc]# cat nedrhealy.com:13.log

Xvnc Free Edition 4.1.2
Copyright (C) 2002-2005 RealVNC Ltd.
See http://www.realvnc.com for information on VNC.
Underlying X server release 70101000, The X.Org Foundation

Thu Dec  6 08:31:06 2007
 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on port 5913
 vncext:      Listening for HTTP connections on port 5813
 vncext:      created VNC server for screen 0
Could not init font path element /usr/share/X11/fonts/OTF, removing from
Could not init font path element /usr/share/X11/fonts/CID/, removing

Thu Dec  6 08:40:59 2007
 Connections: accepted:

Thu Dec  6 08:41:07 2007
 Connections: closed: (reading version failed: not an

Thu Dec  6 08:41:26 2007
 HTTPServer:  completed HTTP request
[root nedrhealy .vnc]#

rhelv5-list mailing list
rhelv5-list redhat com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]