[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[rhelv5-list] remote desktop breaks bond0?




We have an X4600 running 5.1 will all updates applied. The four ethernet interfaces are bonded (mode 4).

When a remote desktop is opened on the system, the kernel starts reporting dropped members of the team (small snippet):

Dec 11 14:15:45 artemis kernel: NETDEV WATCHDOG: eth2: transmit timed out
Dec 11 14:15:45 artemis kernel: bonding: bond0: link status definitely down for interface eth2, disabling it Dec 11 14:15:45 artemis kernel: e1000: eth1: e1000_clean_tx_irq: Detected Tx Unit Hang
Dec 11 14:15:45 artemis kernel:   Tx Queue             <0>
Dec 11 14:15:45 artemis kernel:   TDH                  <76>
Dec 11 14:15:45 artemis kernel:   TDT                  <92>
Dec 11 14:15:45 artemis kernel:   next_to_use          <92>
Dec 11 14:15:45 artemis kernel:   next_to_clean        <6f>
Dec 11 14:15:45 artemis kernel: buffer_info[next_to_clean]
Dec 11 14:15:45 artemis kernel:   time_stamp           <1663745ee>
Dec 11 14:15:45 artemis kernel:   next_to_watch        <77>
Dec 11 14:15:45 artemis kernel:   jiffies              <166374a9a>
Dec 11 14:15:45 artemis kernel:   next_to_watch.status <0>
Dec 11 14:15:47 artemis kernel: e1000: eth1: e1000_clean_tx_irq: Detected Tx Unit Hang
Dec 11 14:15:47 artemis kernel:   Tx Queue             <0>
Dec 11 14:15:47 artemis kernel:   TDH                  <76>
Dec 11 14:15:47 artemis kernel:   TDT                  <92>
Dec 11 14:15:47 artemis kernel:   next_to_use          <92>
Dec 11 14:15:47 artemis kernel:   next_to_clean        <6f>
Dec 11 14:15:47 artemis kernel: buffer_info[next_to_clean]
Dec 11 14:15:47 artemis kernel:   time_stamp           <1663745ee>
Dec 11 14:15:47 artemis kernel:   next_to_watch        <77>
Dec 11 14:15:47 artemis kernel:   jiffies              <16637526a>
Dec 11 14:15:47 artemis kernel:   next_to_watch.status <0>
Dec 11 14:15:48 artemis kernel: e1000: eth2: e1000_watchdog_task: NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX Dec 11 14:15:48 artemis kernel: bonding: bond0: link status definitely up for interface eth2. Dec 11 14:15:49 artemis kernel: e1000: eth1: e1000_clean_tx_irq: Detected Tx Unit Hang
Dec 11 14:15:49 artemis kernel:   Tx Queue             <0>
Dec 11 14:15:49 artemis kernel:   TDH                  <76>
etc (on all interfaces, not just eth2)


As soon as the remote login is gone, this stops happening. The switch does show the links going down as the kernel reports the problem.

Our remote x-servers are all Exceed and Cygwin -- it happens with both. This does not happen under heavy load (CPU, IO, Net) unless there is a remote desktop opened up -- and then it occurs with or without heavy load. It does not happen with individual X applications.

We did not see this until the most recent kernel update -- but we rarely needed to use remote desktop before very recently, so it may be something that just never occurred before.

Any ideas?

-- DCP





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]