[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [rhelv5-list] missing automount entries under rhel5.1 with updates



On Sat, 2007-12-22 at 15:46 -0800, Deke Clinger wrote:
> Greetings,
> 
> I'm using RHEL5.1 with updates as of about a week ago with a large-ish
> (6500+ entries) auto.direct map. Browsing is enabled so I see 940-odd
> subdirectories under my mount point, with the balance of the entries
> being beneath those top-level directories.

You don't need to use the browse option with direct mounts it's
irrelevant.

> 
> I've upgraded my kickstart tree since 5.1 to address the automount
> problems in that release (see RH Bugzilla 371341). I'm now running
> kernel 2.6.18-53.1.4.el5 and autofs-5.0.1-0.rc2.55.

That's good.

> 
> My problem now is that the direct map mount point (/prj) is 'leaking'
> entries: after a reboot I'll see my 940-odd directories. But within a
> few hours the subdirectories begin to fall out, sometimes leaving only
> 50-100 entries. Trying to cd into a missing directory gets a 'no such
> diretory'. A reboot will put all the entries back for a few hours.

Or you could just "service autofs restart", which should work OK and
allow existing mounts to continue being used.

> 
> Previous releases (RHEL5 GA, kernel 2.6.18-8.el5xen and
> autofs-5.0.1-0.rc2.42, for example) do not have this problem. I have a
> guest with 120 days uptime that still sees all the subdirs under /prj.
> 
> Has anyone else seen problems like this? I'm not seeing any new
> Bugzilla entries that look similiar. 

I haven't heard anything about this problem.

How about a debug log?
Do you send HUP signals to the daemon?
If you do send the daemon a HUP signal does it refresh the tree or
completely break autofs?
What is the source of your maps?

Maybe we should try the latest revision of autofs in RHEL CVS, at least
I could find out if I have introduced a regression in 5.1 and not
indirectly fixed it already. Clearly it hasn't been through the needed
QA but I'm nearly done with my testing and there are many bug fixes
included.

Has anyone else seen this?
I would really like to get to the bottom of this as soon as possible.

Ian



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]