[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[rhelv5-list] rhel5 dual boot installation- no grub at boot time.



Hi,
I had dual boot with rhel4 and windowsxp. I installed rhel5 by using
edit of older partitions. Installation had no error. After reboot I
have no grub.


I tried rescue and then re-install grub but getting error.

sh-3.1# uname -a
Linux localhost.localdomain 2.6.18-8.el5 #1 SMP Fri Jan 26 14:15:21
EST 2007 i686 athlon i386 GNU/Linux


sh-3.1# grub-install /dev/sda
/dev/sda does not have any corresponding BIOS drive.

partition table as follows.
sh-3.1# fdisk -l /dev/sda

Disk /dev/sda: 80.0 GB, 80060424192 bytes
255 heads, 63 sectors/track, 9733 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sda1 * 1 4462 35840983+ 7 HPFS/NTFS
/dev/sda2 4463 4475 104422+ 83 Linux
/dev/sda3 4476 5750 10241437+ 83 Linux
/dev/sda4 5751 9733 31993447+ 5 Extended
/dev/sda5 5751 6387 5116671 83 Linux
/dev/sda6 6388 6642 2048256 82 Linux swap / Solaris
/dev/sda7 6643 6897 2048256 83 Linux
/dev/sda8 6898 7152 2048256 83 Linux
/dev/sda9 7153 7241 714861 83 Linux


I used grub-shell then which is giving me error of no such partition:

grub> root (hd0,1)
Filesystem type is ext2fs, partition type 0x83

grub> setup (hd0,0)
Checking if "/boot/grub/stage1" exists... no
Checking if "/grub/stage1" exists... yes
Checking if "/grub/stage2" exists... yes
Checking if "/grub/e2fs_stage1_5" exists... yes
Running "embed /grub/e2fs_stage1_5 (hd0,0)"... failed (this is not fatal)
Running "embed /grub/e2fs_stage1_5 (hd0,1)"... failed (this is not fatal)
Running "install /grub/stage1 (hd0,0) /grub/stage2 p /grub/grub.conf "... fail
ed

Error 22: No such partition

did ls and found vmlinuz,initrd and other /boot/ files at the right place.

My grub.conf is

	
i have this information


sh-3.1# cat boot/grub/grub.conf
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd2,1)
# kernel /vmlinuz-version ro root=/dev/mapper/pdc_cfabdbchhep8
# initrd /initrd-version.img
#boot=/dev/sdb
default=0
timeout=5
splashimage=(hd2,1)/grub/splash.xpm.gz
hiddenmenu
password --md5 $1$EfjvUqFA$KRwo.7YS0pE0tkQqqJbnv/
title Red Hat Enterprise Linux Server (2.6.18-8.el5)
root (hd2,1)
kernel /vmlinuz-2.6.18-8.el5 ro root=LABEL=/1 rhgb quiet
initrd /initrd-2.6.18-8.el5.img
title Other
rootnoverify (hd2,0)
chainloader +1


which says grub installed on my second hard disk. Whereas I deselected
my two other hard disks during partitioning (I always follow this rule
as I have important data on other hard disks.).


sh-3.1# grub-install --recheck /dev/sda
grub-install does not support reprobing of device.map when
using a device-mapper based boot device.


sh-3.1# grub-install /dev/sda
/dev/sda does not have any corresponding BIOS drive.


fdisk -l has.


Disk /dev/sda: 80.0 GB, 80060424192 bytes
255 heads, 63 sectors/track, 9733 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sda1 * 1 4462 35840983+ 7 HPFS/NTFS
/dev/sda2 4463 4475 104422+ 83 Linux
/dev/sda3 4476 5750 10241437+ 83 Linux
/dev/sda4 5751 9733 31993447+ 5 Extended
/dev/sda5 5751 6387 5116671 83 Linux
/dev/sda6 6388 6642 2048256 82 Linux swap / Solaris
/dev/sda7 6643 6897 2048256 83 Linux
/dev/sda8 6898 7152 2048256 83 Linux
/dev/sda9 7153 7241 714861 83 Linux


Disk /dev/sdb: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 1278 10265503+ c W95 FAT32 (LBA)
/dev/sdb2 1279 3834 20531070 c W95 FAT32 (LBA)
/dev/sdb3 3835 6390 20531070 c W95 FAT32 (LBA)
/dev/sdb4 6391 9729 26820517+ c W95 FAT32 (LBA)

Disk /dev/sdc: 150.0 GB, 150039945216 bytes
255 heads, 63 sectors/track, 18241 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sdc1 * 1 18240 146512768+ 7 HPFS/NTFS


sh-3.1# cat boot/grub/device.map
# this device map was generated by anaconda
(hd2) /dev/mapper/pdc_cfabdbchhe
(hd0) /dev/sdb


Now why it happened :
1. Even after I deselected other hard disks during
installation/partitioning, grub installation reached other disk?
2.Why am I getting error when I am trying to install grub on my first
hard disk ? /dev/sda ?

Thanks and regards
Anuj Singh.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]