[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[rhelv5-list] Re: installing Red Hat EL 5 on a new Macpro



Geoffrey schrieb:
Kay Diederichs wrote:
Geoffrey schrieb:
I've spent many hours trying to install Red Hat EL 5 on a new Macpro I purchased. I successfully installed Fedora 8 and am actually sending this from that system. The problem is, my primary client at this time requires Red Hat 5.

When I attempt to boot from the Red Hat 5.1 install DVD, I see the following in the logs:

ide-cd: cmd 0x28 timed out
hda: DMA interrupt recovery
lost interrupt
lost interrupt
lost interrupt
lost interrupt

I've tried the Red Hat 5.1 install cd as well as the Red Hat 4 install cd, same problem. Centos 5.1 gives the same issue.

For what it's worth, the dvd drive shows up as /dv/sr0 on Fedora 8.

I've tried creating a boot usb device, no go there either.

I tried "linux askmethod" in order to attempt a network install, and I do get the initial install menus, but any keyboard input is duplicated, thus when I get to the point of entering the IP address for the server, it's impossible: (192.10.10.10 comes out as 119922..1100..1100..1100)

Any suggestions as to how I might proceed would be appreciated.

Specs:

2.5GHz Intel Core 2 Duo
MacBook Pro 17-inch Hi-Res WS
2GB 667 DDR2 SDRAM - 2x1GB
200GB Serial ATA @ 7200 rpm
SuperDrive 8x DL

Thanks for any suggestions.


try installation from DVD with "linux irqpoll" , and also try "linux irqpoll acpi=off"

Once it's installed try to get rid of those parameters in grub.conf.

At least we had to do this with early RHEL5 kernels on the Mac pro.

Thanks for the suggestion. I've since found that I can initiate a successful network intstall by passing the hda=noprobe option at boot. I might give your approach a try, since it would enable me to install from the dvd.

Question is, what do you mean by 'try to get rid of those parameters in grub.conf?' Obviously it would require a simple edit, but I suspect that might be suggesting that I might have problems getting it to boot after doing so?


what I mean is this: _if_ a kernel works without these parameters then this is preferrable. The kernel that is installed from the DVD is normally older than the one you have on a fully updated system, and RedHat keeps fixing bugs and improving hardware compatibility. So there is some chance that you might be able to get rid of these parameters with later kernels.

Of course if you have problems with the kernel after removing those parameters, you have to boot again from the DVD _with_ those parameters, go into "linux rescue", mount the disk, and edit grub.conf to put them back. A bit tedious but straightforward.

HTH,

Kay


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]